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Workbook Guidelines

Welcome to the HyperStudio workbook! We think you’re going to enjoy these activities. Here
are some miscellaneous hints and tips on navigating within HyperStudio and this workbook.

Type Styles and Icons: All menu items that you must use are in italics, while all menus
themselves are in boldface type. Disk names and filenames will be in this
special type.

This icon appears next to all steps required on a one-drive system. If you are running
HyperStudio off of a hard drive or network, you may skip these steps.

This icon appears next to all steps required on a two-drive system. If you are running
HyperStudio off of a hard drive or network, you may skip these steps.

This icon appears next to all steps required on a hard drive or network system. If you are
running HyperStudio off of a single disk drive, you may skip these steps.

At certain points in the workbook, a particularly important procedure or concept will be
discussed, and highlighted with a box like this. Be sure to read these sections very
carefully, and make sure you understand them completely, before going on.

Keyboard Equivalents: Many of the the HyperStudio commands can be duplicated with
keyboard equivalents. These are indicated next to the commands in the menus with the Open
Apple Symbol (G). They are also referred to within the instructions as Apple-.

Moving from card to card: In order to move from card to card within the stack, use either
the Move menu commands or the Apple-> and Apple -< keys. The > key moves to the next
card in the stack, while the < key moves to the previous card.

Here’s a flow chart of how your first stack will look and operate when it’s complete: -

The United States
by
Della Smith

v@n Tourof the Usited Stetes




HyperStudio Workshop Goals

Before you leave the workshop today, you should have completed at least the “Hands-On
Walk Through.” The other activities are provided for more advanced users, or for use in
workshops longer than two hours. Please look over the activities now, so that you’ll have an
idea of the contents of this workbook.

Be sure to check off each activity as you complete it.

If you are an experienced HyperStudio user, you may mark those activities you already know
how to do. If you would like to use a stack that is similar to what would be created in the first
Hands-On Walk Through activity as a building block for the other “advanced” activities that
follow, load the sample stack, USA. 3.Card, from your data disk and proceed to any of the
later exercises.

(J HyperStudio Hands-On Walk Through—pages 3-21

You have just created a three card stack that incorporates HyperStudio’s eight basic skills. To
review, they are:

% Making a card

+» Loading a background

«» Making a button

« Linking a button to a card or sound

< Importing clip art graphics

« Cutting and pasting objects

% Saving a stack

< Running a stack

(d Scanning with the Lighming Scan or the Quickie Hand Scanner—pages 23-28
(J Recording a HyperStudio Stack Onto a VCR Tape—page 29
[ Using the ComputerEyes Video Digitizer—pages 30-34

(J Adding Video from a Laserdisc Player—pages 35-37

(J Using the Edmark TouchWindow—pages 38-39

If you have time, the following are optional enrichment activities.
(J Adding Animation—pages 4146

{1 Resizing a Border—pages 47-51

[J Using Xcmds (Extended Commands)—pages 52-55

{J Creating a Testing Stack—page 56
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Section one

HyperStudio Hands-On Walk Through

Before you begin this activity, please look at the disks placed by your computer.

If you are on a one or two-drive system, there should be five disks. The four with gold labels
are the same HyperStudio disks as are supplied in the HyperStudio package. They all say
“HyperStudio” on them in large type. The actual disk name is in smaller type and is preceded
by a slash mark (like this: /). For example, the HyperStudio demo disk is named

/HS .Demo . Whenever you are asked to place a particular disk in the drive, please look for the
name that is preceded by the slash mark. Please be sure to turn in the four disks with
gold labels at the end of the session!

The disk with the white label is your data disk. Use this disk whenever you save your stack.
Since this disk is yours to take home with you, please write your name on it now. It has a
demo version of HyperStudio on it so that you can run your stack even if you don’t own
HyperStudio. You can also show others how you created your stack. However, since it is a
demo version of HyperStudio, you won’t be able to save any changes to your stack until you
get your own full version of HyperStudio.

Note to hard drive or network users: the data disk is the only disk you will have.

Starting the Program

If HyperStudio has already been launched, go directly to the “Exploring the Paint Tools”
section.

Note to hard drive or network users: simply launch HyperStudio, and skip the next step.
s Insert the /HyperStudio disk into the disk drive.

» Hold down the Apple and Control keys. Press and release the Reset key. Release the Apple
and Control keys.

The disk drive will be accessed. You will see the HyperStudio startup screens.

If you wanted to explore the HyperStudio demo, you could click the green light of the traffic
signal. For now, though, you need to make your own stack.

Exploring the Paint Tools

If you are familiar with paint programs, you may wish to skip this section and go on to Card
#1—The Title Screen.



- » Choose New Stack from the File menu.
 Choose the Round Rectangle from the Tools menu.

- The Round Rectangle looks like this:

() Round Rect.
If you’ve never used this type of paint tool before, this is a good time to practice drawing on
the screen. To do so, position the cursor, which appears as a cross-hair, wherever you’d like
the upper-left comer of the rectangle to appear. As you press down on the mouse button, drag
the mouse diagonally across the screen to the lower-right side of where you want the rectangle
to end. Draw several rectangles on the screen.

« Choose different line widths by choosing Line Size from the Options menu.
« Choose different colors from the Colors menu.

~ You may also wish to draw with some of the other paint tools that work in a similar manner.
Try the following tools if you’d like:

= Freehand ] Rectangle
> Oval ~ [< Polygon
/" Line Tool

Deleting Items on the Screen:

When the screen is full, you have several cﬁoices for erasing what you’ve drawn. They are
using the Eraser Tool or Selector Tool from the Tools menu or choosing Erase Background
or Unda from the Edit menu. The next section details using each process.

» Choose Undo from the Edit menu. This will undo the last action you did.
« Choose the Eraser from the Tools menu. It looks like this:

&F Eraser

While pressing the mouse button, move the eraser over the area you wish to erase. Erase part
- of the screen. You can also erase items by selecting them with the Selector Tool and then
pressing the Delete key. Everything that is selected will be deleted.



» Choose the Selector Tool from the Tools menu. The Selector Tool 100ks like this:

Selector

This is one of the most often-used tools in HyperStudio. Make sure you
understand how to use it!

To use the Selector Tool, click the upper-left side of part of the screen. While pressing on the
mouse button, drag the mouse diagonally across the screen to just past the lower-right side of
what you wish to select. A dotted, rectangular box will appear around the area you have
selected. If you didn’t get the area you wanted, simply click outside the box and try again.
Press the Delete key to delete what you have selected.

* Choose Erase Background from the Edit menu. This will erase everything on the screen.

CARD #1—The Title Screen

In this activity, you will create a small, three-card stack. You will use many of HyperStudio’s
basic features while creating this stack.

In this stack, we will have a yellow background color on each card. The normal, default
background color is white, so we need to change it.

* Set Background Color from the Options menu to yellow. The screen will stay white until
we erase it and make a new one.

» Choose Erase Background from the Edit menu to make the background yellow.
Adding the Border

* Choose the Round Rectangle from the Tools menu. .
» Choose a medium width Line Size from the Options menu.
» Choose the red color from the Colors menu.

» Draw a border, starting at the upper-left corner of the screen. To do so, position the cursor,
which appears as a cross-hair, on the upper-left side of the screen. As you press down on the
mouse button, drag the mouse diagonally across the screen to the lower-right side of the
screen. Release the mouse button. Make the border as big as the monitor screen,
following the outlines of the screen.

If you decide you want to draw the border again, choose Undo from the Edit menu, and try

again. “Undo” only undoes the last step, so you may need to choose the Eraser Tool or Erase
Background from the Edit menu for a completely fresh start. '

Adding the Text

» Choose Text Style from the Options menu.
» Choose “Shaston”, which has already been highlighted as the default font.



« Click “16” as the font size.

» Click in the box next to “Bold” to choose it as the style.
» Click “OK”.

» Choose the Text tool from the Tools menu.

It looks like this:
T Text

» Choose the red color from the Colors menu.
» Click the mouse in the left side of the screen about 1 inch from the top to set where you will
start typing. '
* Type The United States (Press Return.)

(Press the space bar until the cursor is centered under the first line.)

by (Press Return.)
(Press the space bar until the cursor is centered under this line.)
Your Name (Press Return.)

» If necessary, choose the Selector Tool from the Tools menu to move the text. If you need to
erase the text, select it with the Selector Tool and press the Delete key.

- The Selector Tool looks like this:

v+ oelector

To use the Selector Tool, click the upper-left side of the area you wish to select (in this case,
just to the upper-left of any of the text you just typed). You may select all of the text, or
just one word, depending on what needs to be repositioned. While pressing on the mouse
button, drag the mouse diagonally across the screen to just past the lower-right side of what
you wish to select. Release the mouse button when the desired area is selected. A dotted,
rectangular box will appear around the area you have selected. If you didn’t get the area you
wanted, simply click outside the box and try again. To move the selected area, place the cursor
inside the box. While pressing on the mouse button, drag the box to the new location. Click
outside the box to drop it in the new location. '

If you need to start over, simply select the text and press the delete key. This will erase all of
the selected text and give you a fresh screen to use.

(See next page for an example of how your screen should look.)



Your screen should.lpok like this (this is an example of the entire screen):
m .
The United States

by
Della Smith

Adding a Button

Now we will add a button to this page. It will connect to the next card.

» Choose Add a button from the Objects menu.
« Choose the rounded button by clicking on it.
« Press the “Clear” key and type Start
« Click “OK”.
* Read the dialog box and click “Continue”. (This dialog box will only appear the first time a
button is added. If someone else has been using HyperStudio before you, and the computer
wasn’t rebooted, you won’t see this message.)

* Drag the button to the lower-right corner of the screen by placing the cursor inside the button,
pressing down on the mouse button, and moving the mouse so that the button is placed on the
lower-right corner of the screen.

Your screen shouh; look like this:
The United States
by
Della Smith




« Click outside the button to place it. You must always click outside the button
to tell the computer that you’ve chosen a position for the button.

Next, you will see the Button Actions screen. It has many options for what you wish the
button to do. For now, we will connect it to the next card.

* In the upper-left box of the Button Actions screen, under the words “Connect to:”, click in
the radio button next to “Next card.”

» Click next to the “Blocks” transition on the “Select a visual effect” screen.

» Click “OK”.

If you wanted this button to do more, you could choose more actions, but connecting to the
next card is all we want this button to do.

» Click “Done” on the lower-right section of the Button Actions screen.

lé Make sure that your data disk is not wﬁte—protécted! ‘

' * Note to one-drive system users: remove the /HyperStudio disk and insert your data disk
into the drive.

g Note to two-drive system users: insert your data disk into the second drive.

» Choose Save Stack As... from the File menu.

Note to hard drive or network users: be sure to select the location of your data disk by
pressing the TAB key until the name of your data disk (/DATA) appears at the top of the dialog
|__.:> box. This is very important! If you don’t select your data disk as the destination, you will
save onto the hard drive.

» Press the “Clear” key. It is to the right of the Delete key, above the number seven on the key
pad.

* Type USA in the entry box. You must type the file name exactly like this. GS/OS does not
allow spaces in names; you may only enter letters, periods, or numbers.

* Click on “Save”.

You have just created a title screen for your stack. In doing so, you have used paint tools to
create a border and add text. You have also created your first button and saved your stack onto
your data disk. Now we’ll make the next card in your stack.

CARD #2—The Menu Card
Adding Clip Art

This menu card will have buttons that connect to the rest of this stack. We’ll add one button for
now, with a sound effect as a transition from this card to the next. Later, you can add more
buttons to this page when you add to this stack. For now, we’ll add a clip-art drawing that
we’ll use as part of a button.



If you are working with a partner, be sure to trade places at the computer so that each of you
has a turn using the computer.

» Choose New Card from the Edit menu. This creates the second card in your stack.

» Choose Add Clip Art from the File menu.

» Insert the /HyperStudio disk if a dialog box appears requesting it. (This may occur if
HyperStudio needs a part of the program in memory that it hasn’t used before. This only
occurs the first time that you choose certain operations.)

» You will see a dialog box asking you to select a file for the Clip Art. You want a picture from
a different disk, though.

Note to one-drive system users: insert the /HS . Art disk into the disk drive. A dialog box will
appear, informing you that there is no device on-line. Click “OK”.

Note to two-drive system users: remove your data disk from the second drive and insert the
/HS .Art disk into the disk drive.

Note to hard drive or network users: locate the /HS . Art folder on the hard drive and open it.

* Scroll downward through the files by putting the mouse cursor on the “down” arrow, and
pressing the mouse button. Click the Icons file to select it. (There is a folder called “Icons”
on the /HyperStudio disk. This is not the file you’re looking for. Make sure you’ve located
the Icons file on the /HS . Art disk or folder.

* Click “Open”.

« Select the compass by clicking just to the left of the upper-left corner that would be formed if
you drew a box around the compass. While pressing the mouse button, drag the mouse
diagonally across the screen to just past the lower-right side of the compass

Your box should enclose all of the compass and look like this:

B e ko

» Click “OK” at the top of the screen.

» Position the compass on the upper-left side of the screen by placing the cursor m51de the
dotted box, pressing the mouse button, and dragging the box.

» Click outside the box to place the compass on the screen.
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o If there are any stray marks on the screen, select them with the Selector Tool and press the
Delete key to erase them, or use the Eraser Tool.

Now we will fill in the white area that surrounds the compass.

» Choose the Fill Tool from the Tools menu.

The fill tool looks like this:

By Fill Tool

» Choose yellow from the Colors menu.

To use the Fill Tool, place the very tip of the black area (that represents the paint
pouring out of the paint can) in the white area surrounding the compass.
» Click the mouse.

Note to one-drive system users: insert the /HyperStudio disk as directed by the dialog box.
Click “OK”. (This occurs because HyperStudio needs a part of the program in memory that it
hasn’t used before. This only occurs the first time that you choose certain operations.)

There will be a pause, during which you will see the watch cursor for a moment until the color

Adding the Text

» Move the mouse back up to the menu bar. Make sure that you’ve moved all the way to the
top of the screen and that your cursor has changed to a pointer.

» Choose the Text tool from the Tools menu.

« Choose Text Style from the Options menu.

« Click “Geneva” to select it.

« Click next to “Bold” as the style and “12” as the size.

» Click “OK”.

» Choose Set Text Color from the Options menu.

» Click the red square to choose it as the color.

« Click the mouse to the right of the compass icon to position the cursor. Type Tour of the
United States

(See next page for an example of how your screen should look.)
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Your screen should look like this:

Tour of the United States

» Use the Selector Tool to re-position the words, if necessary. Use the same technique as you
did on the Title Screen. ‘

Adding a Button

 Choose Add a button from the Objects menu.

» Click the invisible button style box.

« Click “OK” to accept your choice.

» Drag the dotted box over the compass by placing the cursor inside of the box, pressing down
‘on the mouse button, and dragging the mouse so that the box covers the compass. )

The invisible button must now be sized to better fit the compass. To size the button, you must
place the tip of the pointer cursor on one of the box corners. The tip is the only portion of the
pointer cursor that is “hot”. (In other words, the part that the computer recognizes when it is
clicked.) If you click outside the box, HyperStudio will think that you are finished placing the
box. If this happens, don’t worry. Simply choose “Cancel” on the Button Actions screen and
start over by choosing Add a button from the Objects menu again.

-+ Place the tip of the cursor on one of the box comers.
* Press on the mouse button.
- » Drag the mouse towards the compass icon (while pressing on the mouse button). Make the
box fit the compass by moving the sides of the box in this manner.
+ Click outside the dotted box when you have sized it correctly (to place the button on the
screen).
» Click next to “Next card” in the upper-left “Connect to:” box on the Button Actions screen.
» Choose “Fade to black™ as the visual effect on the “Select a visual effect” screen.
.+ Click “OK” to accept your visual effect.
» Don’t click “Done” yet, since we want this button to also play a sound.
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Adding Sound to a Button

» Click in the box next to “Play a sound” in the upper-right “Actions” box on the Button
Actions screen.

A dialog box will appear, giving you choices as to where the sound originates.

» Click the “Disk file” button.

« Now we need to locate the Beam. Down file from the /HS . Sounds disk.

Note to one-drive system users: insert the /HS . Sounds disk into the drive. A dialog box will
appear, informing you that there is no device on-line. Click “OK”.

Note to two-drive system users: remove the /HS . Art disk and insert the /HS . Sounds disk
into the second disk drive.

Note to hard drive or network users: locate the /HS . Sounds disk.

» Click on Beam.Down to select it, then click on “Open”.

Note to one-drive system users: insert the /HyperStudio disk into the drive as directed.
(This occurs because HyperStudio needs a part of the program in memory that it hasn’t used
before. This only occurs the first time that you choose certain operations.)

» Click “OK”.

A picture of a tape recorder will appear.

» Click “Play” to hear the sound you’ve just added. Adjust the volume, if necessary, with the
slide volume control to the right. When you are finished listening to the sound,
* Click “Done”.

You will now see the Button Actions screen again. You could choose more actions, but this is
all we want this button to do.

* Click “Done” on the lower-right portion of the Button Actions screen.

Note to two-drive system users: remove the /HS . Sounds disk and insert your data disk into
the second disk drive.

Note to one-drive system users: insert your data disk into the disk drive.

e Press Apple-S or choose Save Stack from the File menu.

CARD #3—USA Map

In your last card for this stack, we will add a map of the United States. You will also add the
name of a state with your own voice!

« If you are working with a parmer, trade places at the computer.
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« Choose New Card from the Edit menu.
» Choose Load Background from the File menu.

Note to one-drive system users: insert the /HS . Art disk. A dialog box will appear, informing
you that there is no device on-line. Click “OK”.

Note to two-drive system users: remove your data disk and insert the /HS . Art disk.
Note to hard drive or network users: locate the /HS .Art disk. |
« Scroll down through the files by clicking on the “dowh” arrow. Click the U.S.A. fileto
select it.

+ Click “Open”.

Now we are going to-add an invisible button to the state of Arizona. This button will play a
sound that you are going to record, using HyperStudio’s sound digitizer card and microphone.

If your computer does not have a sound digitizer card and microphone installed, you will need
to save your stack and go to a sound digitizing station. If you have a digitizer and
microphone, you may go directly to “Adding An Invisible Button” without
saving your stack.

To save your stack, (if ybu need to go to another computer to record a sound),

Note to two-drive system users: remove the /HS . Art disk and insert your data disk into the
second disk drive.

the to one-drive system users: insert your data disk into the disk drive.
» Press Apple-S or choose Save Stack from the File menu.

Adding an Invisible Button

» Choose Add a button from the Objects menu.

» Click the invisible button style.

« Click “OK” to accept your choice.

» Move the dotted box over the state of Arizona. Size the box to fit the general outline of
Arizona just like you sized the box around the compass on the last card.

» Click outside the button to place it. ‘

» Leave the “no connection” button checked on the upper-left “Connect to:” portion of the
Button Actions screen.

Adding Sound to the Button

» Click in the box next to “Play a sound” in the upper-right “Actions” section of the Button

_ Actions screen.

« In the dialog box that appears, choose “Record Now”.
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Click the “Record” button. You must hold the microphone very close to your mouth! Say
firmly into the microphone, “This is Arizona”. As soon as you finish speaking, press
any key to stop recording. It is important to press a key quickly to stop recording after
you are finished speaking, since sound files take up large amounts of memory—about 10K per
second.

If you cannot easily hear your voice, adjust the volume slide control. If you still cannot hear
your recording, click the “Record” button again and try hclding the microphone closer to your
mouth and speaking more firmly. You must project your voice—use a “radio announcer”
voice. If there is extra “space” at the end of the recording, you should practice pressing a key
more quickly after speaking so as not to waste memory in your stack.

» Click “Done” when you are finished.
» Click “Done” on the lower-right section of the Button Actions screen.

Adding a Visible Button

» Choose Add a button from the Objects menu.

» Click the square button with a shadow. (The third button style.)

» Press the “Clear” key and type Back.

* Click “OK™.

» Move the button to the Gulf of Mexico (between the bottom of Texas and Florida) by placing
the cursor inside the button, pressing the mouse button, and dragging the button.

» Click outside the button to place it.

Normally, you would choose “previous card” as your destination. However, occasionally you
will need to connect cards that are not next to each other. The following procedure is used to
connect cards that are not immediately next to each other.

> Choose ~another card” in the “Connect to:” section on the upper-right portion of the Button
Actions screen. Important: DO NOT click “OK” in the dialog box until you’ve
read the following instructions!

You will first see a dialog box instructing you to move to your destination. It is very
important that you move to the card you want this button connected to before you click
“OK”. Once you click “OK”, you will tell HyperStudio that this is the card you want your
button connected to.

 Use the Move menu to move to the next card.

Continue to move, using the Move menu, until you see the card that says “Tour of the United
States” (with the compass icon). It will say “Card 2” in the upper-right comer.

» When you reach the card that is your destination, click “OK” in the dialog
box.

» Choose “Fastest” as the visual effect on the “Select a visual effect” screen.
« Click “OK”.
» Click “Done” on the lower-right area of the Button Actions screen.




Your card should look like this:

« Try out your button by clicking on it. If it doesn’t connect to the Menu card, you will need to
delete the button (see below) and start again with the “Adding a Button” instructions.

Deleting A Button

If you create a button that doegn’t work the way you intended, you can delete it. The following
steps detail how to delete a button.

IMPORTANT! If you do not want to delete the button you just created, go on to “Saving
Your Stack™!

"_- Choose the Button Editing Tool from the Tools menu. It is the letter B with a circle around
it”C]ick the button that says “Back”.

A dotted, moving box will enclose the button, showing that it is the active item.

« Press the Delete key.

That’s all there is to deleting a button. Now you need to create the button again. Go back to the
“Adding a Button” instructions and start again.

Saving Your Stack
Note to two-drive system users: remove the /HS . Art disk and insert your data disk.
¢ Insert your data disk into the disk drive.

* Press Apple-S or choose Save Stack from the File menu.

If you’re working with a partner, be sure to save your stack onto both (if you have two) data
disks. To save onto the second data disk,

15
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Note to one-drive system users: insert your partner’s data disk into the disk drive.

Note to two-drive system users: insert your partner’s data disk into the second disk drive.

Note to hard drive or network users: be sure to select the location of your data disk by
pressing the TAB key until the name of your data disk (DATA) appears at the top of the dialog
box. This is very important! If you don’t select your data disk as the destination, you will
save onto the hard drive.

o Choose Save Stack As from the File menu.

» Press the “Clear” key.

» Type USA in the entry box. Be sure to type the name exactly like this.
* Click “Save”.

That’s all there is to it! You have just made a three card stack that incorporates HyperStudio’s
eight basic skills. To review, they are:

< Making a card

 Loading a background

< Making a button

% Linking a button to a card or sound
 Importing clip art graphics

+# Cutting and pasting objects

« Saving a stack

< Running a stack

With these eight basic skills, you can do anything in HyperStudio! Later, you can add more
cards to this stack. Eventually, you can create a masterpiece that incorporates all of
HyperStudio’s major features!
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Section two

CARD #4—The Help Card

In this activity, we will add a Help screen to the stack. It will be accessed by a button on the
menu card. This Help screen will contain a border and a text item.

Adding a Border

» Choose Background Color from the Options menu. Set the color to white.
» Choose New Card from the Edit menu.
 Choose Load Background from the File menu.

Note to one-drive system users: insert the /HS . Art disk into the disk drive. Click “OK” in
the dialog box that appears informing you that no volume is on-line.

Note to two-drive system users: remove your data disk and insert the /HS . Art disk.
Note to hard drive or network users: locate the /HS . Art disk.

« Click Borders to highlight (and choose) the file.

« Click “Open” to open it.

« Choose the Selector Tool from the Tools menu.
« Enclose all of the borders within the heart border with the selector tool. To do so, click

outside the upper-left portion of the interior border. While pressing the mouse button, drag the
mouse diagonally to just past the lower-right portion of the interior border. Your screen should

look like this:

o File Edit Move Tools Bluects Colors Ontmns Card 1

» Once you have successfully selected the interior borders, press the delete key.
« If the interior of the border turns black, simply choose the Fill Tool and fill the area with
white. (The area turned black because you happened to start the selection of the borders on a
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black pixel. If you select an area and then delete it, the selected area becomes whatever color on
which your selector box begins.)

« If you needed to use the Fill Tool, move the mouse back up to the menu bar. Make sure that
you’ve moved all the way to the top of the screen and that your cursor has changed to a
pointer. Choose the hand from the Tools menu.

If you accidentally erase part of the heart border, press Apple-Z (to Undo your last action) and
try it again. If you choose Undo, you will need to go back to “Adding A Border” again.

If there are any stray marks on the screen that need to be erased, select and delete them, or use
the Eraser tool.

That’s all there is to it! You have just added a border to your screen. The next step will be to
add some text to it.

Adding a Text Item

In this activity, we are going to add a text item to this help screen. Text items are very easy to
use, and they function almost as a word processor within HyperStudio. Since they can have a
scroll bar, text items can also hold large amounts of information, without taking up more of the
screen than you desire.

Note to one-drive system users: insert your /HyperStudio disk into the disk drive. (This
occurs because HyperStudio needs to get the font information from the disk each time the font
or font size is changed.) '

* Choose text style from the Options menu.

+» Choose Century 18, Bold as your text style. If you don’t have this font available, choose any
font you’d like.

¢ Click “OK” to accept these choices.

 Choose Set Text Color from the Options menu.

» Click the black square to choose it as the color.

e Choose Add a text item from the Objects menu.

* Read the dialog box and click “OK”. (This will only happen the first time you add a text
item. If someone has been using HyperStudio before you, and the computer wasn’t rebooted,
you may not see this message about dragging and sizing the rectangle to the proper position.)
» Place the cursor inside the box. Do not click outside the box! If you do, HyperStudio will
think that you are finished placing this text item.

» While pressing the mouse button, drag the comer of the box to the upper-left corner of the
screen.

» Place the tip of the arrow on the very edge of the lower-right comer of the box.

» While pressing the mouse button, drag the corner of the box down and to the right so that it
extends to the bottom of the screen and about half-way across the screen. (Your box should
take up about one-half of the screen.) If you accidentally click outside the box while doing this,
simply click “Cancel” on the next screen and try again.

« Click outside the box when you have sized it correctly.



You will now see a dialog box that details the attributes your text item may have.
« Click in the check-box next to “Draw scroll bar” to make it checked.
« Click the “Add new text” button.

If you had some information already stored as a word processing file, you could click

“Get text from disk” and import the text from a disk. You can directly import any -
AppleWorks Classic file, or convert any other type of file to an ASCII text file and then import
it.

« Click with the cursor inside the text box.

» Type Click on an icon or button.

Now you may type in some information about how this stack works. You may also type what
this stack is about. You may type as much information as you wish. Notice that as you reach
the end of the box, HyperStudio automatically scrolls up another line. If you wish to see the
beginning of your text, move the scroll bar on the right with your mouse. Intentionally make a
typing error and continue typing. You may correct your error as easily as you can with a word
processing program. Simply move the cursor to where the error is and correct it! (Click the
cursor after the mistake, press the Delete key as needed, and retype.)

Your screen should look like this:

Click on an icon
or button.

Adding a Button

e Choose Add a button from the Objects menu.

« Choose the rounded button style by clicking in it.

« Press the Clear key and type Back.

» Click “OK”.

« Place the cursor inside the button, press the mouse button, and drag the button to the lower-
right portion of the screen.

e Click outside the button to place it.

» Choose Connect to: another card on the Button Actions screen.

* Use the Move menu to move to card #2, the menu card.
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« Click “OK” when you see the menu card.

« Choose any visual effect you’d like from the “Select a visual effect” dialog box.

« Click “Done” on the lower-right portion of the Button Actions screen since we don’t want
this button to do anything else.

Your screen should look like this:

@ (Clickonanicon [
or button.

Note to two-drive system users: remove the /HS . Art disk and insert your data disk.
« Insert your data disk into the disk drive.

» Choose Save stack or press Apple-S.

Connecting to the Menu Card

Now we will connect this screen to the Menu Card. The button will be an invisible button
placed over a typed question mark.

 Choose “Move to previous card” two times from the Move menu to go to the Menu Card.
(Card #2)
e Choose Text Style from the Options menu.

Note to one-drive system users: insert the /HyperStudio disk and click “OK” as directed.
(This occurs because HyperStudio needs to get the font information from the disk each time
the font or font size is changed.)

¢ Click Century as the font, bold as the style, and 24 as the size.

» Click “OK™ to accept these choices.

» Choose the Text tool from the Tools menu.

« Choose the red color. '

» Position the cursor on the lower-right portion of the screen. Click the mouse to place it.
» Type a question mark. '

(See next page for an example of how your screen should look:)



The screen should look like this:

N

wz Tour of the United States
$

—

Adding a Button

* Choose Add a button from the Objects menu.

» Choose the invisible button style by clicking on the invisible button style box.

« Click “OK” to accept your choice.

« Move the button over the question mark by placing the cursor inside the box, pressing the
mouse button, and dragging the box over the question mark.

The invisible button must now be sized to better fit the question mark. To size the button, you
must place the tip of the pointer cursor on one of the box corners. The tip is the only portion of
the pointer cursor that is “hot”. (In other words, the part that the computer recognizes when it
is clicked.) If you click outside the box, HyperStudio will think that you are finished placing
the box. If this happens, don’t worry. Simply choose “Cancel” on the Button Actions screen
and start over by choosing Add a button from the Objects menu.

« Place the tip of the cursor on one of the box comers.

« Press on the mouse button.

* Drag the mouse towards the question mark (while pressing on the mouse button). Make the
box fit the question mark by moving the sides of the box in this manner.

« Click outside the button to place it.

« Choose Connect to: another card on the Button Actions screen.

« Connect it to the Help card by choosing Next Card from the Move menu until you see the
Help card (the card with the text item on it).

» Click “OK” when you see the Help card.

» Choose the “Fastest” screen transition effect.

» Click “OK” on the screen transition page.

» Click “Done” on the lower-right section of the Button Actions screen.

» Insert your data disk and choose Save stack or press Apple-S.

That’s all there is to it! Try it out by clicking on the question mark.
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Use this picture for scanning when you are using the LightningScan or
Quickie worksheet.
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Section three (LightningScanj
Digitizing Images with LightningScan

In this activity, you will scan an image with a LightningScan hand-held scanner. By rolling the
scanner across a surface, the image is translated to the computer as a series of dots. This
process is called digitizing. If you are using the Quickie scanner, please use the
instructions in the next section.

If you will be using a scanner at a different computer, be sure to save your stack onto your data
disk. Take your data disk and your workbook to the scanner station. Be sure t0 work quickly,
so that others will be able tc use the equipment. If there is someone ahead of you, watch what
they are doing so that you’ll have a better idea of how the equipment works. If there are several
people waiting, perhaps you should start a sign-up list and go on to another activity until it is
your furt.

Setting the Scanner

Before we begin, you must run the LightningScan software. To do so, boot the LightningScan
software disk.

The first step is to set the switches to their proper settings. On the left-hand side of the scanner
is the dithering switch. It is next to the Start button.

Move the dithering switch to the “Lerter” setting. It is the position to the far right. This
setting is used for scanning line art. The other settings are used for scanning photographs.

Set the resolution switch to the 200 DPI setting. The resolution switch determines the size
and amount of detail in the image. This switch is on the back of the scanner, and has markings
from 1-4 on it. Set the switch to 2.

The brightness dial is on the back of the scanner next to the resolution switch. It is a dial
marked “light” and “dark”. In the middle of the dial is a vertical, black bar. Place this bar in the
middle. The brightness dial determines the brightness of the scanned image. It works just like
the darkness controi on a copy machine works.

In summary, the switches should have the following settings:

* Dithering Switch: “Letter” setting
¢ Resolution Switch: 2
« Brightness Dial: halfway point

If you are the first person using this scanner today, you will need to choose Ser Slot from the
Scanner menu. The scanner will be in slot two. (If the scan doesn’t work, ask the workshop
leader for some help.)

Now we are ready to scan the image. We will add a clip-art image of a giobe. Later, you will
import this into the title screen of your stack.
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« Pull down on the Scanner menu. Click New Scan.. _

« Click “OK™ to accept the default setting of “Display during scan?” and “16 Greys”.

Placetheplcture of the globe on a flat surface. Itlsverylmponantthattheunageyou’llbe
scanning is on a completely flat surface! Otherwise you will have distortion in the image.

» Position the scanner (on the paper) about one inch above the globe.

» Press the “Start” button that is located on the left side of the scanner. Slowly and steadily,
drag the scanner across the image, from the top to the bottom. If you move the scanner too
qmckly, the computer will make a low-pitched chckmg sound to warn you that part of the
image may have been lost. :

'vAsyouarescanmng,youwﬂlseetheplctureyouarescannmgontbecomputerscreen Seeing

the picture is useful since it allows you to see if you’re scanning straight.
« When you reach the end of the image, press refurn on the keyboard.

Oncethelmageshowsuponthescreen,usethescrollba:stoseetheenureunage If, for
some reason, youd;dnotgetaclear copy of the image, go back and scan the image again.

« Pull down on the File menu and select “Save As™.
» Type Globe as the name of the picture.

+ Click next to the Apple Preferred button and next to 640.

« Insert your data disk. : '
» Click the “Disk” button until the name of your data disk, “Data”, appears as the destination.

Note to hard drive or network users: be sure your data disk is selected. Press the TAB button,
1fnecessary tmnlthenameofyomdatadlskappearsmthetopofthedmlogbox.

« Click Save.
Importing Scanned Images into HyperStudio
Now we will add the image you just scanned to your HyperStudio stack. Ifyou have been
using the scanner at a special station, please go back to your computer so that someone else can
use the scanner. If you are returning to your computer, you will need to have HyperStudio
launched.
Note to one-drive system users: insert the /HyperStudio disk into the disk drive.
» Choose Open Stack from the File mehu,
* Place your data disk in the drive.
» Click the USA stack.
Next, we will add the image to the title screen, the first card you made.

« Choose “Add clip art” from the File menu. v
» Choose Globe as the file to add and click “Open”.

» Draw a box around the globe by chckmg just outside the upper-left section of the globe. Drag
the mouse (holding the button down) to the lower-right section of the globe. When there is a
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box completely around the globe, click “OK™ at the top of the screen. (If part of the globe is
not inside the box, click outside of the box and do this step again.)

After the above step, you’ll be returned to your title screen with the globe in the middle of the
screen.

« Place the cursor in the middle of the box.
.« Press down on the mouse and drag the box to the lower-left comer of the screen.
« Click outside of the box to place the graphic.
« Choose the Fill Tool from the Tools menu.
« Choose yellow from the Colors menu.
« Click the pointed tip of the Fill Tool in the white area surrounding the globe.

Here is an example of how your screen should look:

The United States
by
Della Smith

l Start

That’s it! You have nov}_scatmed an image and imported it into your stack!

« Insert your data disk into-the disk drive.
« Press Apple-S or choose Save Stack from the File menu.
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Section three (Quickie)

Digitizing Images with the Quickie Scanner

In this activity, you will scan an image with a Quickie hand-held scanner. By rolling the
scanner across a surface, the image is translated to the computer as a series of dots. This
process is called digitizing.

If you will be using a scanner at a different computer, be sure to save your stack onto your data
disk. Take your data disk and your workbook to the scanner station. Be sure to work quickly,
so that others will be able to use the equipment. If there is someone ahead of you, watch what
they are doing so that you’ll have a better idea of how the equipment works. If there are several
people waiting, perhaps you should start a sign-up list and go on to another activity until it is
your turn.

Setting the Scanner

Before we begin, you must run the Quickie software. To do so, boot the Quickie software disk
if it isn’t already booted.

« Click the Quickie button on the title screen.
¢ Puil down on the Display menu and make sure that the last item says “Switch to 320
mode”. If it doesn’t, choose it by highlighting it with the mouse.

The next step is to set the switches to their proper settings. On the left-hand side of the scanner
is the dithering switch. It is next to the Start button.

Move the dithering switch to the “Letter” setting. It is the position to the far right. This
setting is used for scanning line art. The other settings are used for scanning photographs.

Set the resolution switch to the 200 DPI setting. The resolution switch determines the size
and amount of detail in the image. This switch is on the right side of the scanner, and has
markings from 1-4 on it. Set the switch to 2.

The brightness dial is on the back of the scanner next to the resolution switch. It is a dial
marked “light” and “dark”. In the middle of the dial is a vertical, black bar. Place this bar
under the “T” of the word “Light” . The brightness dial determines the brightness of the
scanned image. It works just like the darkness control on a copy machine works.

In summary, the switches should have the following settings:
* Dithering Switch: “Letter” setting

* Resolution Switch: 2

* Brightness Dial: underneath the “T” in “Light”

Now we are ready to scan the image. We will add a clip-art image of a globe. Later, you will
import this onto the title screen of your stack.

» Pull down on the Quickie menu. Choose “Grey Smoothing” .



The next screen shows the Smoothing dialog box. You have three color options for your scan
mode. For line art, black and white should be chosen. The other options would be appropriate
if you were scanning photographs and other images that contain grey shading.

» Choose pseudo-gray.

-+ Click “OK” to accept your choice.

s Pull down on the Quickie menu. Make sure that “portrait” and “blend lines” have a check
mark next to them. If they don’t, click them.

« Place the picture of the globe on a flat surface. This is very important! If you aren’t scanning
a flat image, you will have a distorted picture.

« Position the scanner (on the paper) about one inch above the globe.

« Choose Scan Image from the Quickie menu.

A dialog box will appear that says, “Ready to Scan”.

+ Click “OK” to continue.

« Press the “Star?” button that is located on the left side of the scanner. Slowly and steadily,
drag the scanner across the image, from the top to the bottom.

As you are scanning, on the computer screen you will see the picture you are scanning. Seeing
the picture is useful since it allows you to see if you’re scanning straight.

» When you reach the end of the image, press return on the keyboard.

» Once the image shows up on the screen, use the scroll bars to see the entire image. If, for
some reason, you did not get a clear copy of the image, go back and scan the image again.

o Pull down on the File menu and select “Save As™.
» Type Globe as the name of the picture.
» Click next to the Apple Preferred button.
» Insert your data disk.
« Click the “Disk” button until the name of your data dlsk, “Data”, appears as the destination.

Note to hard drive or network users: be sure your data disk is selected. Pness the TAB button,
if necessary, until the name of your data disk appears in the top of the dialog box.

» Click Save.

Importing Scanned Images into HyperStudio

Now we will add the image you just scanned to your HyperStudio stack. If you have been
using the scanner at a special station, please go back to your computer so that someone else can
use the scanner. If you are returning to your computer, you will need to have HyperStudio
launched

Note to one-drive system users: insert the /HyperStudio disk into the disk drive.
» Choose Open Stack from the File menu.

» Place your data disk in the drive.
» Click on the USA stack.
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Next, we will add the image to the title screen, the first card you made.

» Choose “Add clip art” from the File menu.

* Choose Globe as the file to add and click “Open”.

» Select the globe by clicking just past the upper-left portion of the globe. While pressing the
mouse button, drag the mouse to just past the lower-right portion of the globe. A dotted box
should enclose all of the globe. If it doesn’t, click outside the box and try again.

» Click “OK”.

» Place the cursor in the middle of the dotted box.

» Press down on the mouse and drag the box to the lower-left comer of the screen.

« Click outside of the box to place the graphic.

» Choose Standard Palette from the Options menu to restore the palette to its ongmal colors.
s Choose the Fill Tool from the Tools menu.

« Choose yellow from the Colors menu.

« Click the pointed tip of the Fill Tool in the white area surrounding the globe.

Your screen should look likethis:

The United States
by
Della Smith

That’s it! You have now scanned an image and imported it into your stack!
» Insert your data disk into the disk drive.
* Press Apple-S or choose Save Stack .
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Section four

Videotaping Your HyperStudio Stacks

Transferring your stack onto a VCR tape is very simple. In this activity, we have already

connected the computer to the VCR, and you-can go on to the section titled “Recording Your
HyperStudio Stack onto a VCR Tape”. However, if you’d like to connect your Apple IIGS to
your VCR in the future, please see Appendix A for detailed information. :

If you will be using the VCR at a different computer, be sure to save your stack onto your data
disk. Take your data disk and your workbook to the VCR station. Be sure to work quickly, so
that others will be able to use the equipment. If there is someone ahead of you, watch what
they are doing so that you’ll have a better idea of how the equipment works. If there are several
people waiting, perhaps you should start a sign-up list and go on to another activity until it is
your turn.

Recording Your HyperStudio Stack onto a VCR Tape

Recording your stack onto a VCR tape is very easy. It is useful as a way to show others a
stack, without needing a computer. Some teachers send tapes home to show parents the
HyperStudio projects their students have created. This is a great public relations tool for
showing parents, the community, administrators, school board members, etc. the exciting
things your students are doing with technology! Remember, in this way, VCRs become “the
printers of the 90°s!”

1. First, rewind the tape if necessary.

2. Next, load the USA stack that you’ve made.

3. While the tape is recording, you will be clicking on the buttons in the stack. Everything you
see and hear on the Apple IIGs will be recorded on the tape. If you have a microphone and a
stereo mixer box for input, while the stack is running you can also provide narration.

4. When you are ready to begin, activate the “record” mode of the VCR.

5. Click the buttons of your stack. Remember to pause after clicking each button.

6. Using the mouse, pull down on some of the menus. It is not necessary to choose any
particular item. This is simply to show that the menus are active. :

7. Stop the VCR. Rewind the tape and play it. Notice that even your menu bar actions from
step six were recorded. This is useful in that you could tape an entire presentation and then
show it to an audience—all with just a VCR, a monitor, and your tape!
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Section five

Digitizing an Image from a Video Camera
with ComputerEyes

In this activity, you will videotape your parmer. You will then add the digitized picture of
him/her to a card in your stack.

If you will be using Computer Eyes at a different computer, be sure to save your stack onto
your data disk. Take your data disk and your workbook to the Computer Eyes station. Be sure
to work quickly, so that others will be able to use the equipment. If there is someone ahead of
you, watch what they are doing so that you’ll have a better idea of how the equipment works.
If there are several people waiting, perhaps you should start a sign-up list and go on to another
activity until it is your turn.

Setting Up ComputerEyes

« Boot the ComputerEyes software. If a dialog box appears informing you that the
ComputerEyes card isn’t in Slot 1, contact your workshop leader.

¢ Pull down on the Image menu and choose Capture Settings to set up ComputerEyes for
best results with HyperStudio. Make sure the following settings have been chosen. Change the
settings to match, if necessary.

° Dithering should be “on” :

° Capture speed should be “normal”
° Palette should be “unfrozen”

° Auto-calibrate should be “on™

° Color/levels = 16

© Color separation = 2

« Choose “OK” after verifying these settings.

» Choose View Video Input from the Image menu to monitor the image coming from the
video camera or laserdisc player.

 Choose Capture B/W from the Image menu to begin the d1g1nzmg process. This will take
approximately six seconds.

If you're capturing a live subject, he/she should hold as still as possible during the capture
process. You'’ll get best results with a solid color background, preferably with good contrast to
your subject. Make sure you have good lighting, also. Position the camera for a video snapshot
of your partner’s face, with his/her face filling about 1/4 of the total screen area.

« When the capture is finished, a new window will appear with a 320-mode graphic version of
the 1 image on the screen.
» To view the picture in the 640-mode used by HyperStudio, choose View Special from the
Image menu. A dialog box will appear allowing you to choose in which mode the image
should be displayed.
« Choose “Super Hi-Res 640 B&W,” and “Paint from raw data”. This latter choice tells
ComputerEyes to build the 640 image from the raw data gathered from the video image. If



O & %

31

you were loading a 320 mode graphic scanned earlier where only the final graphic was
available, this “raw data” option would not be offered.

« Click “OK” to see the image.

« Click the mouse when you’re done viewing the image.

» To save the 640 image to disk, choose Save Special from the File menu. As before, choose
“Super Hi-Res 640 B&W,” and “Paint from raw data”.

« Insert your data disk into the disk drive. _

» Click the “Disk” button until the name of your data disk, “Data”, appears as the destination.
» Enter the name you wish to use for this image (you can use Test . 640 for this example if
you wish). Be sure the name you use contains only letters, numbers, and/or periods, and
doesn’t have any spaces!

« Click “Save”.

Using A ComputerEyes Image in HyperStudio

Now, let’s use the captured image within HyperStudio. If you have been using Computer Eyes
at a special station, please go back to your computer so that someone else can use the
equipment. If you are retumning to your computer, you will need to have HyperStudio
launched.

If your stack is still on your computer, skip to the Choose New Card step.

Note to one-drive system users: boot the /HyperStudio system disk.

Note to two-drive system users: boot the /HyperStudio system disk.

Note to hard drive or network users: launch HyperStudio.

+ From the File menu, choose Open Stack. Insert your data disk and load the USA stack.

» Choose New Card from the Edit menu.

There are two ways of adding digitized images. One is as clip-art, where the image is
“painted” onto the background. The other is as a graphic object, where your image will remain
separate from the background. We’ll add it as clip-art for this activity.

» Choose “Add Clip-Art” from the File menu.

« Insert your data disk into the disk drive.

+ Load the file with the video picture (Test . 640 if you used the earlier suggestion), by
clicking on the name, and then “Open”.

A window will appear with the digitized image in it.

» Use the mouse, with the Selector Tool, to cut out the part of the image that you’d like to use
in your card (about 1/2 of the screen at most).

» Click “OK” at the top of the window.

The window will disappear, and you’ll see the graphic you selected floating on the card.
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« Put the mouse on the image, press the mouse button, and drag the image to the upper-right
corner of the screen.

» Click outside the box to drop the image in position. That’s it! The image is now part of the
background graphic

« Insert your data disk and press Apple-S or choose Save Stack from the File menu.

Adding a Text Item

This card is going to be an “About the Author” card that is accessed from the menu. To the left
of the picture you digitized, you are going to add a text item with some autobiographical
information in it,

» Choose Add a text item from the Objects menu.
» Read the dialog box and click “OK”.
You will see a box that is very similar to the Selector Tool’s box. It is sized and moved in the

. same way, t0o0.
- » Place the cursor inside the box. Do not click outside the box! If you do, HyperStudio will

think that you are finished placing this text item!

» While pressing down on the mouse button, drag the box to the upper-left comer of the
screen. -

* Place the tip of the arrow on the very edge of the lower-right comer of the box.

» While pressing down on the mouse button, drag the box down so that it extends to the
bottom of the screen. If you accidentally click outside the box while doing this, simply click
“Cancel” on the next screen and try again.

» Click outside the box when you have sized it correctly.

You will now see a dialog box that details the attributes your text item may have.
» Click next to “Draw scroll bar”.
» Click the “Add new text” button.

Now you may type in some information about the person whose picture is on this cz}rd.'

» Choose text style from the Options menu.

» Choose Century 18, Bold as your fext style.

» Choose Set Text Color from the Options menu.

» Click the black square to choose it as the color.

« Click inside the text box to set the insertion point for new text..

You may type as much information as you wish. Notice that as you reach the end of the box,
HyperStudio automatically scrolls up another line. If you wish to see the beginning of your
text, move the scroll bar on the right with your mouse.

(See the next page for an example of how your screen should look.)
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Your screen should look like this:

|

This is an
example of
your screen.

« Insert your data disk into the disk drive.
* Press Apple-S or choose Save Stack from the File menu.

Button Connections

Now we need to add a button to this card so that you can return from this card to the menu.
We will also add a button to the menu card that accesses this card.

« Choose Add a button from the Objects menu. Choose the shaded rectangular button. Type
Back and click “OK”.

* Place the cursor inside the button, click the mouse, and drag the button to the lower-right
portion of the screen.

» Click outside the button to place it.

¢ Click “Connect to another card”.

 Use Move to Card... from the Move menu and type 2, to move to Card #2.

* Click “OK”.

 Choose “Venetian Blinds” as the visual effect.

e Click “OK”.

e Click “Done”.

« Insert your data disk and press Apple-S or choose Save Stack from the File menu.
» Click the button you’ve just created to go to the menu card.

Now we will add a button to the menu card that accesses the card with the ComputerEyes
digitized picture that you just made. This button will be a graphic item.

» Make sure that you are at the menu card.
e Choose Add clip art from the File menu.

Note to one-drive system users: insert the /HS . Art disk into the disk drive.

Note to two-drive system users: remove your data disk and insert the /HS . Art disk into the
disk drive.

33
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Note to hard drive or network users: locate the /HS .Art disk.

* Load the Education file. _

« Select the picture of the teacher in front of the black board.
« Position the picture underneath the compass.

« Choose the Text tool from the Tools menu.

Note to one-drive syStem users: you may be prompted for the /HyperStudio disk at this
step or on the next step. If so, insert it as directed and click “OK”.

» Choose text style from the Options menu.

« Choose Geneva 12, Bold as the font and style.

* Type About the author

» Use the Selector Tool, if necessary, to align the text.

« Choose add a button from the Objects menu.

« Click the invisible button style.

* Click “OK”.

» Size the box around the teacher icon.

» Click outside the box.

e Click “Connect to another card”.

« Use the Move to next card from the Move menu to move to the ComputerEyes digitized
picture card.

¢ Click “OK” when the proper card is displayed.

« Choose “right to left” as the transition.

s Click “OK” and then “Done”. .

o Insert your data disk into the drive and press Apple-S or choose Save Stack from the File
menu. :

That’s it! You have successfully digitized a video image with ComputerEyes, imported it as
clip art into HyperStudio, and added a Text Item!

Typical uses for digitized pictures would include putting students’ pictures in their reports; a
stack on local history with illustrations captured from a videotape; or an “open house” school
map stack with pictures of students and staff on various cards.
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Section six

Adding Laser Disc Video To HyperStudio

Interactive video in HyperStudio is based on use of the Pioneer 2200, 4200, or 8000 Laser

- Disc player, and optionally, the Apple II Video Overlay Card. The laser disc player is attached
to the Apple [IGs modem port, using a simple modem cable with the proper connectors on
each end.

If you will be using the laser disc player at a different computer, be sure to save your stack
onto your data disk. Take your data disk and your workbook to the laser disc station. Be sure
to work quickly, so that others will be able to use the equipment. If there is someone ahead of
you, watch what they are doing so that you’ll have a better idea of how the equipment works.
If there are several people waiting, perhaps you should start a sign-up list and go on to another
activity until it is your turn.

Connecting Your Laser Disc Player to an Apple IIGs

For this activity, we have already connected the laser disc player to the computer. You may
skip ahead to the “Adding Laser Disc Video to Your Stack” instructions. However, if you’d
like to do this another time, the following are instructions on the necessary connections.

» Access the control panel on your IIGs and change the “Slots™ setting for slot two to Modem.
» Change the modem baud rate setting to 4800.
* Reboot your computer to make these settings permanent.

Now we will hook up the cables. You will need a Pioneer CC-04 cable and' two or three
standard RCA cables, such as the cable that attaches a monitor to an Apple Ile or Apple Ilc.
These cables are also available at Radio Shack, part #420-2309, $5.69 for four 3-ft cables.

» First, attach the round end of the Pioneer CC-O4 cable to the modem port of fhe IGs. Attach
the other end of the cable to the laser disc player.

Wlth VOC:
» Plug one end of a RCA cable into the “video in” (the top Jack) of your VOC.
» Attach the other end to the “video out” on the laser disc player.

o Attach the RGB monitor cable to the VOC RGB connector (the wide, 15 pin connector).
Note that this is not the usual RGB connector on the GS itself.

Without VOC:

» Attach a RCA cable from the “video out” on the laser disc player to the “video in” on a
regular TV monitor.

Audio Connection:

With the second RCA cable, we will hook up the audio portion of the laserdisc.
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« Plug one end of the RCA cable into the left “audio out” jack on the laser disc player.

» Plug the other end into the “audio in” jack on an external speaker or into the “audio in” on the
back of your TV monitor. If you have two external speakers, hook up a third RCA cable from
the right “audio out” jack on the laser disc player to the second speaker.

That’s all there is to it!
Adding Laser Disc Video to Your Stack

Adding a video sequence to a stack is easy. In this activity, you will add a laserdisc video to a
new card that will be connected via a button to card #3 (the card with the map of the United
States). Normally, you would choose a sequence that corresponded to a button on a particular
card. Since you may be using any one of several laserdiscs for this activity, the sequence that
has arbitrarily been chosen for this activity may not be directly related to a U.S. map, but it will
illustrate the general principles of videodisc use.

» Place the /HyperStudio disk into the disk drive.

« Choose Open Stack from the File menu.

« Place your data disk in the disk drive.

« Click the USA stack.

» Place your laserdisc in the player. Make sure that the laserdisc player is on.

* Choose New Card from the Edit menu. This is the card the video will be placed on.

» Choose “Add a Video” from the Objects menu. Click “No” in the dialog box asking if you
want to show the video in the screen border. _
HyperStudio will then display the remote-control box on the bottom of the screen and a video
rectangle in the middle.

« If there is a button labeled “Start” in the upper-left comer of the remote-control box, click it.
Otherwise, proceed to the next step.

» Make the video rectangle larger by putting the tip of the cursor pointer on the upper-left

“handle,” pressing on the mouse button, and dragging the rectangle up to the upper-left comner.

of the screen. Then drag the upper-right handle to the upper-right corner. Your rectangle should
take up the entire screen above the remote-control box.

» Click the “Begin” radio button, press the “Clear” key, and enter 00780 as the “Begin”
frame number. :

» Click the “End” radio button, press the “Clear” key, and enter 01130 as the “End” frame
number.

You can adjust the starting and ending points by clicking on “Begin” or “End”. For example,
to choose a different beginning frame, click the number in the “Begin” box.

Click the Play or Step buttons to find the beginning of the sequence you want to use. If the disk
is playing, clicking on Step or Pause will stop the disk on that frame, and update the frame
number register with the current frame number. Remember, if you want to change the end
point, click that frame number before using Step or Pause.

 You can view your video by pressing the “Test” button. When you are finished viewing the
sequence,
» Click the “Keep” button.
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» Add a rounded button that says “Back”.

» Place it on the bottom of the screen.

» Connect it to card #3, the map of the United States by using the Move menu.
» Choose fastest as the transition effect.

» Click “OK” and “Done”.

» Click the “Back” button.

« On card #3, the US map card, Add a rectangular button that says, “See the video!”
» Choose Connect to: another card.

» Move to the the card with the video by using the Move menu.

« Choose fastest as the transition.

« Click “OK” and “Done”.

« Insert your data disk.

e Press Apple-S or choose Save Stack.

Try it out!

Summary: HyperStudio can automatically control the laserdisc player to show any sequence
that you would like to associate with a particular card, or even a single button.

Card videos are used the most often, with a video sequence being shown with an
accompanying card. This card can have a text and/or graphic explanation of what is shown on
the video monitor. However, button videos can be useful in those cases where you want a’
single screen with a variety of possible video selections associated with the single screen.

What you have stored as part of your stack is the starting and ending frame
numbers of the video sequence, not the actual video images. Your computer
must be attached to a laserdisc player in order to view the sequence again.
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Section seven

Using the Edmark Touch Window

.The Edmark TouchWindow can be a very useful addition to a HyperStudio system. It is

particularly useful for very young users, peoplewith special needs, or even parents at Open
House! _ -

Using the TouchWindow is very simple:

1. The TouchWindow attaches to the game port connector on the back of the GS. Locate this
connector on the back of the computer, on the side away from the power cord, and plug the
TouchWindow connector into this. It is not necessary for this exercise to use the bolts to
permanently secure the connector.

2. Use a rubber band around the top of your GS monitor to hold the top of the TouchWindow
in place, and tuck the TouchWindow cable under the bottom of the monitor to hold the bottom
of theTouchWindow in place for the moment.

3. To activate the TouchWindow in HyperStudio, find the Preferences dialog box under the
Apple in the menu. In that dialog box, you’ll see a choice labeled “Use TouchWindow”. Just
checking this box won’t immediately do anything, other than to let HyperStudio know what
your intentions are!

4. Click “OK”. At this point, a dialog box will appear explaining how to calibrate the
TouchWindow. This is so that you can use HyperStudio and the TouchWindow on monitors
other than the standard Apple RGB monitor, if you wish.

To calibrate the TouchWindow, you’ll need to show it the corners of the ACTIVE part of your
computer screen. First, touch the upper-left comer of the menu bar, and HOLD your finger
steady and in place until you hear a beep. Then, touch the lower-right corner of the active
screen area (not just the outer colored border), and again hold steady until you hear a beep.

5. At this point, a new dialog box should appear, telling you the TouchWindow has been
calibrated. Before you choose “OK,” notice that as you drag your finger around over the
screen, the pointer follows under your finger. Now, TOUCH the OK button!

6. At this point, you’re back in HyperStudio, and everything you could do with a mouse, you
can do with the TouchWindow. For example, try choosing a paint brush, and then a color from
the menus, and then draw some lines on the screen. You can also use both your finger, and the
mouse interchangeably. Realistically speaking, it is not very practical to use the TouchWindow
for authoring an application, but it is VERY practical for clicking on

buttons in a running stack. Most buttons are fairly large, and are easy to hit with the
TouchWindow, and the TouchWindow actually becomes a very nice way for anyone to
navigate HyperStudio stacks.

7. Pull down on the File menu, and choose Open Stack. Once you’ve loaded a stack, choose
the Browse tool (the hand) from the Tools menu. Navigate through the stack by touching the
buttons.



8. When you’re done exploring the TouchWindow, remember to go to the Preferences dialog
box and turn OFF the TouchWindow option before you unplug the TouchWindow (otherwise
the computer will be looking for something that’s not there).

NOTE: be sure to turn off the computer before plugging or unplugging the TouchWindow (or
any other computer peripheral).
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Bonus Activities

The following sections are optional bonus activities. They are more advanced than the
exercises you’ve already completed, but introduce you to some of the more powerful features
of HyperStudio: animation, resizing borders, Xcmds, and more.
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Bonus activity one

Creating an Animation

In this activity, you will make a new help screen with an animation. Since your old. help screen
has a text item on it, we will first need to delete the text item.

* Go to the help screen.

» Choose the Pointer from the Tools menu. (This allows you to edit all objects.)
« Click inside the text item.

¢ Press the Delete key.

The Text

Note to one-drive system users: insert the /HyperStudio disk into the disk drive.
Note to two-drive system users: insert the /HyperStudio disk into the disk drive.

* Choose the Text Tool.

¢ Choose red from the Colors menu.

e Choose Text Style from the Options menu.

» Choose Shaston 16 Bold as your text style.

» Position the cursor in the top one-third of the screen on the left side.

 Type Click a topic...

« If necessary, position the text with the Selector Tool so that your card looks like the picture
below.

& File Edit Move Tools Oluects Colors Options

Cllck on a topic... |
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The Animation—Creating the “Movie”

In this section, you will be creating a movie-like animation. Creating the frames for the
animation, and accessing it with a button, are two completely independent actions. First, you
will use HyperStudio and the current card as a temporary screen to create a movie. Next, you
will restore the original image and create a button to play the animation.

+» Choose Add Clip Art from the File menu.

* Note to one-drive system users: insert the /HS . Art disk into the disk drive. Click “OK” on
the “no volume on-line” dialog box message.

g Note to two-drive system users: insert the /HS . Art disk into the second disk drive.
l::> Note to hard drive or network users: locate the /HS . Art disk.

» Click the Icons file to select it as the file you want to view.

* Click “Open”.

« Select the light bulb by positioning the cursor just past the upper-left portion of the light bulb,
pressing the mouse button, and dragging the mouse diagonally down and to the right, until
there is a box around the light bulb.

« Click “OK”.

« Position the light bulb on the left-hand, lower section of the screen by positioning the cursor
inside the box, pressing the mouse button, and dragging the light bulb.

If there are any stray marks on the screen, you can erase them with the Eraser Tool.

Your card should look like this:

Cl1ck on a topic...

* Note to one-drive system users: insert your data disk into the disk drive.

Note to two-drive system users: remove the /HS . Art disk and insert your data disk into the
disk drive.



Note to hard drive or network users: in the next step, be sure to choose your data disk as the
destination! Press the TAB key until the name of your data disk appears in the top of the dialog
box.

» Choose Save Screen from the File menu. Name the file Bulbl

Your file must be named exactly like this, with no spaces!

« After the screen has been saved, use the Selector Tool to move the light bulb one inch to the
right. .

« Choose Save Screen from the File menu and save it as Bulb2

« Use the Selector Tool to move the light bulb one inch to the right.

e Choose Save Screen from the File menu and save it as Bulb3

* Use the Selector Tool to move the light bulb one inch to the right.

» Choose Save Screen from the File menu and save it as Bulb4

You have now created a small, four frame “movie” on the disk. It can be used like “clip-art”
on any card or stack at any time.

« Choose Load Background from the File menu to restore the original screen.

* Click Bulbl to select it.

» Click “Open”.

Adding a Button to Activate the Animation

» Choose Add a button from the Objects menu.

» Choose the rounded style by clicking in it.

» Press the Clear key and type See the animation!

» Place the cursor on the button and drag it to lower-left side of the screen.
« Click outside the button to place it.

¢ Click next to the Activate Animation box on the Button Actions screen.
 Choose Bulbl as the animation to attach to this button.

What you need to do now is to create a “window” that will show the moving light bulb
sequence you just created. You will place this “movie” of the moving light bulb over the
original light bulb image that is already on the screen.

A rectangle will appear in the middle of the card. This rectangle is the window in which your
animation will appear. You will see the upper-left portion of the screen in the window.

(See the next page for an example of how your screen should look.)
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Your card will look like this:

o File fdit Move Jools Ghjects 8920:5 fations

[See the uninution!]

« Place the hand inside the rectangle and press on the mouse button.
« Slowly move the mouse upwards and to the left until the light bulb appears in the rectangle.

DO NOT CLICK THE MOUSE OUTSIDE THE RECTANGLE!! If you
accidentally do so, HyperStudio will think you are finished and create the animation. (If this
happens to you, don’t worry. After the animation is created, click “Activate Animation” twice
and start over.)

Now we will move the animation window to the bottom of the screen so that your “movie”
will appear on the bottom of the screen.

* Move the hand onto any part of the frame. When the hand is on the edge of the frame, the
cursor will show as a cross-hair. The cross-hair indicates that dragging with the mouse will
allow you to move and size the frame. :

» Making sure that the cursor shows as a cross-hair, press the mouse button and drag the
window so that it is over the original light bulb image.

¢ Place the cross-hair on one of the “handles” (small dark squares) and drag to make the
rectangle about two inches high vertically and as wide as the clear area of the screen. Make sure
that your rectangle doesn’t overlap any part of the buttons or border.

(See the next page for an example of how your screen should look.)
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Your screen should look like this:

& N {dit Move Tools Ohjests Colors Gptiens Card 1

o Click on g topic...
[See the unhution!] ) ‘ ’ uck

» As you change the size of the rectangle, the light bulb may occasionally move out of view. If
it does, drag the interior of the window with the hand until the light bulb reappears.

« Align the light bulb in your window so that it is on top of the light bulb that is already on the
screen. If you don’t align the two graphics, when your animation “movie” starts, the first
frame will “jump” or flicker, since the moving animation is in a different place than the
stationary light bulb.

Aligning the Graphic

Align the two light bulbs by moving the light bulb with the hand cursor, or adjusting the
frame, as needed. You can tell if the two images are aligned by clicking with the hand cursor
inside the rectangle. If the light bulb jumps, they are not aligned.

There are two techniques for aligning the graphics. Use the technique you like best.

1. Move the light bulb in the window in the same direction that the image jumps when
you click the mouse. Continue moving the light bulb until it no longer flickers when you click
the mouse.

2. Use the mouse to pull up the bottom of the window until you can see top half of the
light bulb in the window, and the bottom half of the other light bulb on the screen.

(See the next page for an example of how your screen should look.)
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Your screen will look like this:

o File {dit Move Tools 923599:5 folors Gptions

Click on a topic...

. m.«f
J‘W‘u

See the animation! ]

Then, adjust the animation window until the two images line up perfectly. Pull down the
bottom of the window until it covers the screen image of the light bulb.

» Click outside the rectangle. A dialog box will tell you that the animation is being created.

» Click in the Rate box and delete the default setting by pressing the Clear key. Make sure that
you press the delete key until the cursor is at the far left-hand side of the box.

« Enter a rate of 15. (This is how fast your animation will move across the screen. A rate of 5
is fast, and 45 is slow.)

» Click in the Repeat Count box and delete the default setting. Make sure that you press the
delete key until the cursor is at the far left-hand side of the box.

* Enter a repeat count of 3. (This sets how many times your animation will repeat.)

* Click “Done”.

* Insert your data disk and choose Save stack or press Apple-S.

That’s it! Click the button to see your animation!

In summary, the animation you created exists as clip-art files on the disk. When activated by a
button, only the “mini-movie” you created is embedded in the stack.

¢ Animation files can be used anywhere at any time.
 Animations are not played from the disk or made by “flipping” between cards;

HyperStudio attaches the animation sequence to the button. In fact, you can copy and paste the
button and the animation will follow!
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Bonus activity two

Resizing a Border

In this activity, you will learn how to make a border the size you want it, no matter what size
the original border is.

» Choose Background Color from the Options menu. Set the color to white.
» Choose New Card.
 Choose Load Background.

Note to one-drive system users: Insert the HS . Art disk into the disk drive. Click “OK” in the
dialog box that appears informing you that no volume is on-line.

Note to two-drive system users: insert the /HS . Art disk into the second disk drive.
Note to hard drive or network users: locate the /HS . Art disk.

- Highlight Borders as the file. Click “Open” to access it. You will only use the “Stars”
border for this card. You’ll need to erase the graphics inside and outside the border.

* Choose the Selector Tool from the Tools menu. Click in the white area just past the upper-
left blue band with the stars on it. While pressing the mouse button, drag the mouse to the
opposite, lower-right corner. Make sure that the dotted, rectangular box encloses the entire blue
band with stars, without accidentally cutting off the points of the stars. If it doesn’t, click
outside the box and try again.

 Choose Copy Background from the Edit menu or press Apple-C. Now that the area of the
screen we’ll be using is copied onto the clipboard, we will erase this screen.

» Choose Erase Background from the Edit menu or press Apple-E.

» Choose Paste Background from the Edit menu or press Apple-V.

« Click outside the dotted box to place the background on the screen. Since we only want to use
the star border, we need to erase everything inside it.

« Using the Selector Tool from the Tools menu, select the area inside the star border. To do
so, click in the white area just past the upper-left comer of the green border with the yellow
curlicues. While pressing the mouse button, drag the mouse to the opposite, lower-right ,
corner. Make sure that the dotted, rectangular box encloses the entire green and yellow border.
If it doesn’t, click outside the box and try again. :

e Press the Delete key to erase what you have selected.

Now you should have only the star border on your screen. If any extraneous marks are on the
screen, erase them with either the Selector Tool or the Eraser from the Tools menu.

» If the interior of the border tumns black, simply choose the Fill Tool and fill the area with
white. (The area turned black because you happened to start the selection of the borders on a
black pixel. If you select an area and then delete it, the selected area becomes whatever color on
which your selector box begins.

Sizing the Border Vertically
Now we need to make this border parallel the sides of the screen. To do so, we need to make

this border wider and taller. We will be using the Option key to make a copy of portions of the
border.
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» Using the Selector Tool from the Tools menu, select the entire border. To do so, click just
outside the upper-left comer of the border. While pressing the mouse button, drag the mouse
to the opposite, lower-right corner. Release the mouse button.

« Move the border to the upper-left corner of the screen. To do so, place the cursor inside the
dotted box. While pressing the mouse button, drag the mouse so that the upper-left corner of
the border is in the upper-left comer of the screen.

Now we will make the border taller by using the Option key.

» Using the Selector Tool, select the lower half of the star border. Be sure to start your selected
area in the middle of a star. This will make it easier to align the two halves of the border later.
To select the lower-half of the border, click to the left of the middle of a star halfway down on
the left side of the border. While pressing the mouse button, drag the mouse to just past the
lower-right corner of the border. A dotted, rectangular box should enclose the lower half of the
border. :

Your screen should look like this:

| & File Edit Move Tools Objects Colors Options ]

Now we will make a copy of what is inside the dotted box and “paste” it onto the lower
portion of the existing border. This will make the border taller. The Option key, when used in
conjunction with the selector tool, makes a copy of what has been selected.

» Place the cursor inside the border. While pressing the Option key, press on the mouse and
drag the border towards the lower half of the screen. Make sure you press the Option
key and not the Apple key! The Option key is the second key to the left from
the space bar, immediately to the right of the CAPS LOCK key, and says
“option” on it.
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« As you are moving the copy of the lower half of the border, your screen will look like this:

« When the border is close to the outside edge of the old border, align the lower half with the
top.half and click outside the box. If you move the border too far towards the lower part of the
screen, the old lower edge of the original border will show through.

Your screen will look like this:

| w File Edit Move Tools Objects Colors Options |

Since the border may not be as tall as the screen yet, you may need to repeat this process once
more.

« Using the Selector Tool, select the lower half of the border.

» Place the cursor inside the border. While pressing the Option key, press on the mouse and
drag the border towards the lower half of the screen.

» When the border is as tall as the screen, align the two portions and click outside the border to
drop it in place.

(See the next page for an example of how your screen should look.)
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Your screen will look like this:

| & File Edit Move Tools Objects Colors Options |

Sizing the Border Horizontally
Now we need to make the border as wide as the screen.

« Using the Selector Tool, select the right half of the star border. To do so, click in the white
area above the middle of the border. Again, you’ll want to start your selection in the middle of
a star to make lining up the pattern easier later on. While pressing the mouse button, drag the
mouse to just past the lower-right comer of the border. A dotted, rectangular box should
enclose the right half of the border. Release the mouse button.

Your screen should look like this:

| & File Edit Move Tools Objects Colors Options

e e Sic ke ke e ke S ke i Sic ke i




« Place the cursor inside the border. While pressing the Option key, press on the mouse
and drag the border towards the right side of the screen.

« Click outside the box when your border is as wide as the screen.

Your screen will look like this:

| & File Edit Move Tools Objects Colors Options |

e i e e e ke A e e e e S i Sic Sic i

* Insert your data disk into the disk drive.

« Choose Save Stack from the File menu or press Apple-S.

That’s it! You have just resized a border to fit your needs. You can use this same process to
make a border of any size.

It may help you to think of this process as being similar to laying wallpaper. You simply line
up the pattemns on each sheet. You just used the Option key to make your own, instant copies!
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Bonus activity three

Using XCMDs In HyperStudio

What are XCMDs? XCMDs (Extended Commands) are routines written in Assembly
Language, C, or Pascal that allow you to extend the power of HyperStudio as a programming
environment.

Adding an XCMD is easy. In this activity, you will create two stacks that demonstrate two of
the XCMDS that are included with HyperStudio. The first will be the Find XCMD that lets
you locate and highlight a bit of text within a text field. The second is how to show a 320 mode
picture inside of HyperStudio.

FIND Stack

To start off, we need to do some file moving. XCMDS are separate files from stacks, and they
won’t get involved unless we put them in the same area of the disk as our stack.

You’ll need a new disk from the workshop instructor: Apple’s /System.Disk.

Note to hard drive or network users: you’ll also need to get the four HyperStudio system disks
from your instructor. You won’t be using the network/hard drive for this exercise.

« Boot the System Disk. Wait for the Finder screen (with the garbage can in lower right corner)
to appear.

e Manually eject (with the disk drive button) the /System.Disk.

« Insert the /HS . DEMO disk into the disk drive.

» Double click the HS . Demo disk icon.

e Drag the scroll bar to the bottom of the window.

* Double click the XCMDS folder.

 Double click the FIND folder. Drag the FIND window to the lower-left comer.

« Manually eject the /HS . Demo disk.

« Put in the /Data disk.

« Double click the Data disk icon.

« Choose New Folder from the File Menu. Clickce on the untitled folder icon, then move the
mouse up and down over the icon until the cursor changes to an I-beam. When that happens,
double click to highlight the whole word. Then type “Find”. Press the Return key to accept the
name.

Now we need to add the Find Xcmd to your disk.

« Drag the file HS . XCMD to the Find folder, and release it. You may need to move the Data
window in order to see the the Find window.

« Follow the prompts during the switching of disks.

« Drag both disk icons (HS . Demo and Data) into the trash.

« Insert the /HyperStudio disk into the drive.

« Double click the /HyperStudio disk icon.

 Double click the HyperStudio icon that is in the window.

e Follow the prompts during the switching of disks.
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There. Now we’ve got that file in the same area of the disk as where we will build our stack.
We are ready to begin by creating a Text Item and some text to search.

« At the Traffic Light, pull down the File menu and choose New Stack.

« From the Objects Menu choose Add A Text Item. Click Continue.

» Drag the dotted line box to the upper-right corner of the screen. Enlarge the box until it is
approximately the size of half the screen. Click outside the box when you’ve sized it properly.
» When the Text Item Attribute dialog comes up, click “Add New Text.”

« Add text to the text box. Move the cursor into the box and type anything you’d like. (The
actual text is unimportant. We are just setting up something to search through. Be sure
whatever you type includes the word “the,” however.)

Now that the text box is set up, let’s save this for posterity.

 From the File menu, choose “Save Stack As”.

» Manually remove the disk from the drive.

« Put in the data disk. You may get a message “There are no disks on-line”. Click OK.

* Double click the Find folder to openit.

« Name this stack FIND.TEST

e Click Save.

» Press Apple-O to load the stack again. We’re doing this because the XCMD isn’t actually in
memory until we OPEN a stack!

¢ Open the Find folder.

*Open Find.Test.

All set. Now let’s make our button!

e Choose Add A Button from the Objects menu.

« Select the shadowed button and enter in this name: Find “the”

« Move the button to lower-left side of the screen. Click outside it to place it.

« From the Button Actions screen choose “Trigger XCMD”. The Text to Pass is: the.

e Click OK.

» That’s all we want this button to do, so click Done.

« Press Apple-S to save the stack.

 Open your stack with Open... from the File menu. The XCMD file is only brought in when
loading a stack.

Now, try it!
Clicking once should highlight the first instance of the text. Clicking a second time finds the

next occurrence. (Or, you can also use Shift-Apple-F to find the next occurrence without
pressing the button!).
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DISPLAY 320 Stack

To start off, we need to do some more file moving. We need to put more XCMD:s in the next
area where we are going to make a stack

« Quit HyperStudio. Insert the System Disk. Wait for the Finder screen (with the garbage can
in the lower right corner) to appear.
* Remove the /System Disk.
« Put in the /HS . Art disk.
» Double click the /HS .Art icon. -
« Drag the scroll bar to the bottom of the window.
« Double click the Test . 320 folder. Move the Test . 320 window down to the bottom of
the screen.
» Manually eject the /HS . Art disk.
« Insert the /Data disk into the disk drive. The disk should still be open on the desktop.
 Choose New Folder from the File Menu. Clickce on the untitled file, then move the mouse
up and down over the icon until the cursor changes to an I-beam. When that happens, double
click to highlight the whole word. Then type Display . Press the Return key to accept your
input.
« Drag the file HS . XCMD to the Display folder, and release it.
» Follow the prompts during the switching of disks.
« Drag the file Butter£ly to the Display folder, and release it.
» Follow the prompts during the switching of disks.
« Drag both icons (HS . ART, DATA) into the trash.
« Insert the /HyperStudio disk into the drive.
« Double click the /HyperStudio disk icon.
« Double click HyperStudio icon in the window.
» Follow the prompts during the switching of disks.
« At the Traffic Light, pull down on the File menu and choose New Stack.

There.
To see exactly why this XCMD is needed, we’ll perform a nice little experiment here.

« Insert your data disk.

* Open Display.
* Open Butterfly.

Just for fun, do a Load Background from the File Menu. Choose the But terfly picture
from the Di splay folder on the data disk. Click OK to the warning about colors being lost.

Okay. See the problem? There are two forms of graphics that utilize Super Hi-Res. The 640
mode is the one that HyperStudio and many other GS programs utilize. 320 mode graphics
have more colors but are limited to 40 characters across the screen. 640 mode graphics have
fewer colors, but twice the resolution, which gives you 80 characters across the screen. When
HyperStudio reads a 320 mode graphic, it brings in the palette but is unable to utilize it, since
its structure is incorrect. This is what causes the color distortion.

The Display.Xcmd solves this problem by altering the screen in a manner which “fools”
HyperStudio into displaying a 320 picture correctly.
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» Choose Erase Background from the Edit Menu to clean up the mess we just made.

» From the File menu choose “Save As...”

« Manually eject the disk from the drive.

» Insert the data disk. You may get a message “There are no disks on-line.” Click OK if you
do.

» Double click the Find folder to open it.

e Type the name Display.Test

« Press Apple-O to open the stack again. We are doing this because the XCMD isn’t in
memory until we OPEN the stack. Remember?

All set. Now for our XCMD magic...

« Pull down the Object Menu and choose Add A Button. Make this one invisible.

» Push the button up to the upper-left corner and resize it so it covers the whole screen. Press
Return to accept.

« At the Button Actions screen, choose Trigger XCMD.

» At the Text To Pass prompt, enter a 1, then click OK.

« That’s all we want to do with this button, so click Done.

» Use Apple-M to hide the menu bar.

* Press Apple-S to save the stack.

 Open your stack with Open... from the File menu. The XCMD file is only brought in when
loading a stack.

Are you ready? Good.

Click in the center of the screen. Ahhhhh. The butterfly appears, looking very nice this time.
Much better. If you’d like to see it again, choose Apple-O to open your stack again. Then just
click.

During this you’vé learned that: XCMDs must be copied into the same folder as your stack;
they are accessed, just like any other button actions, from a button; they are told what to do by
the text that is passed to them; and that they aren’t half as hard to use as they sound!
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Bonus activity four

Creating a Testing Stack

1. Create a short stack (2-3 cards) that asks a question, with answers given by clicking on
buttons identified as “Correct Answer,” “Alternate Answer,” or “No Test Function.” For
example, you could create a stack that asks the user to click the button that-has the correct
word, or spelling of a word, for a color on the card. Make sure that the buttons you have
identified as the “Correct Answer,” “Alternate Answer,” or “No Test Function” also
connect to another card.

2. Save this first stack on your data disk.

3. Create a second stack that will be used to view the test results.

4. Go to the Preferences menu, and check “Advanced User.”

5. Create a text field on the first card of your second stack that gets its data from the file
HS.Test.Results. When the “embedded” vs. “disk based” dialog box appears, choose “disk
based”.

6. Save your new stack to your data disk.

7. Load your first stack, and create a button at the end that links to the second stack. Save this
first stack back to disk again by pressing Apple-S.

8. Move to the first card in your stack, try out the test buttons, and branch to the second stack.
Examine the results as displayed in the text field. Notice that each time you go back to the first
(testing) stack, new data will be added to the HS . Test . Results file, which in turn will be
displayed in the text field in the second stack.

Bonus aétivity:

Write a short Applesoft BASIC program, which is branched to by the first stack, and which
prints out the final test score recorded in the HS . Test .Results file.
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Bonus activity five

HyperStudio Workshop Suggestions

Put yourself in the position of your students, and create a report on one of the following topics:
I. Solar System Report

II. Tour of the USA

III. Computers

IV. Any subject that interests you.

First, on paper, make a short list of the kinds of objectives you would give your students for a
short (two class period) project. For example:

“Create a report on a state in the US. Include a video relevant to your subject, pretending that
you are a reporter gathering news footage that will be included in your presentation. Etc.”

Your stack should begin with a title page with the project name and the names of you and your
partner. The second card can be a menu of any kind, including a menu made up of different
graphic items that the user would click. (For example, you could use the full-screen graphic of
the Solar System on the /HS . Art disk as a “menu” to branch to information on each of the
planets).

No matter what your subject matter, try to incorporate each of the following techniques into
your stack. Check off each on this page as you include each item:

» Your own voice as a response when a button is clicked somewhere.

« A card with no menu bar. (suggestion: the title screen)

* A “read-only” text item with a scroll bar.

» A graphic item (as opposed to the usual “Add Clip-Art” choice).

* Check “Advanced User” in the “Preferences” dialog box, and add a sound and a graphic that
will be disk based, rather than the usual embedded type. (You may have to use Sound Shop to
move the sound from the /HS . Sounds disk to your own data disk. A graphic file can be
moved by first loading the graphic as a “background,” then immediately doing a “save screen”
to save the file on your own data disk.)

¢ Get one of the border patterns from the “Borders” file (on the /HS . Art disk), and use the
Option key and selector tool to make copies of the pattern to create a larger border.

e Use the video camera and ComputerEyes to capture a digitized picture of yourself, and create
an “About the Author” card with a scrolling text field that tells a little about you.
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« Use the Quickie or LightningScan hand-held scanners to tumn the picture of the globe or other
items (at the digitizing station) into some clip-art to use in your project.

« An auto-timed button that takes the user back to a main screen, goes to a help card, offers a
voice prompt, or some other spontaneous action.

" » A moving object animation: move an airplane, flag, or other object horizontally or vertically

across the screen.
* A “blinking” word or object when a button is pressed. (This is a two-frame animation).

* A “pop-up” graphic when a button is pressed (This is a one-frame animation. Create this by
using “Save Screen” to save a single image, named, for example, Lion. 1).

* A card with a video sequence (Add a Card Video). Press a button on one card that takes you
to the card with the attached video. Another button on that card retumns you to the first card. Try
to use the paint color, rather than the “video rectangle” to create the window that the video will
show through.

» Use “Replace Colors” to replace each of the colors in the USA map with purple (this
becomes the key color when used with a video). If you don’t specifically select an area with the
selector tool, the color replacement will be done over the entire screen. Save the final screen as
background art for future stacks with “Save Screen” in the File menu.

» Create several cards that use the same background, but which have different buttons or text
items (or graphic items) on them. Check “Don’t erase background” in the Preferences dialog
box. Try drawing something on the first (“master”) card to see how the added graphics show
up on all the other cards. Be careful not to use any of the paint tools on any of the secondary
(repeated) cards, or else they will no longer be duplicated background cards.

« If you have the time, create some buttons that test the users knowledge of a few simple facts.
Each button should move to the next card in addition to being marked “correct” or “alternate”
answer. The last button in the set of cards should connect to a second stack called
“Test.Reader”. This stack will be a one-card stack with a disk based text field that loads the file
HS.Test.Results off your disk. Another button on that card can connect back to the first
card in your main project stack.



Appendix A

Classroom Display and Recording
of Computer Presentations

(or, “the VCR As A Printer!”)

This section is designed to help you explore the exciting new idea of using your classroom
TV/monitor for computer-based presentations, and using the VCR as a “printer” for the
computer. Once set up, you’ll be able to record student presentations and send them home to
parents; you can record class projects and share them with other teachers and administrators;
you can create training tapes for other staff members in your school or district; you can even
create “portfolios” of projects to take to conferences and other meetings to share what you’ve
been doing with computers—without having to take any more equipment than a single
videotape!

The Basic Principles

The underlying principles to this whole process are very simple: There are two signals (or to be
more direct, “flavors” of wires) you’ll need to be aware of. One is the video signal, which
carries the picture from the computer to the VCR, and from there to a classroom TV or
monitor. The other is the audio signal, which carries the sound from the computer to the
VCR, and on to the TV or monitor.

It is NOT necessary to know anything about electronics, such as voltage levels, engineering
details of audio and video signals, or anything else. Essentially, it’s no more complicated than
attaching the devices with different colored pieces of string.

First, The VCR-to-TV/Monitor Connection -

We start with this because this is something that we will assume you already have set up and
working. Many “AV Carts” in schools are currently equipped with a large (27 for example)
TV or monitor, with a VCR provided. The VCR is connected to the TV or monitor one of two
ways. They are reviewed here for information purposes. If you can already play a videotape on
the VCR and see it on the TV on the cart, then you do not need to make any adjustments to the
setup. '

If you are just now getting a VCR, and haven’t yet connected it to the TV or monitor on the
cart, then follow the directions that accompany the VCR. The AV specialist in the school may
be able to help. If all else fails, you can also call Roger Wagner Publishing, Inc., and request
technical assistance.

Computer-to-VCR Connection

The following assumes that you can put a tape in your VCR, press “Play,” and normally
watch the tape on your TV or monitor. That is, you get both the audio and video from the tape
on the TV/monitor.
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The information that follows concentrates on connecting your Apple IIGS to the VCR. When
properly attached, you will not only be able to use your classroom TV/monitor for
presentations (in full color, and without having to dim the lights!), but you’ll get great sound
from the Apple IIGS, and be able to tape any computer graphics and sound presentation shown
on that setup! '

The VCR: Look at the back of the VCR. There has to be some kind of input connection for
what the VCR will record. It will be one of the following types of connections: either a direct
“Audio/Video In” connection, or an “Antenna/Cable” input.

Note a pair of input connections marked “Video In” and “Audio In”. Look at what kind of
mechanical connection is expected.

Video In: This is where a direct video signal is accepted. The connector will be:

a) The most likely is a “phono” (also called “RCA”) connector.

b) The other possible (but fairly rare) connection is called “BNC”. If this is the kind of
connector you have, you’ll need an adaptor so that you can use a standard cable later on for the
connections. The adaptor you want is Radio Shack #278-254 (about $2.50). This will be
discussed further a little later.

Audio In: This is where the audio signal is accepted. Like the Video In, the connector may be
either a phono or a BNC connector. If it’s a BNC connector for the Audio In, then you’ll need
a second BNC adaptor (same part # as above).

Some VCR’s support stereo sound, and so have both a Left and Right channel Audio In
connector. In this case, we’ll use only the Left channel. ,

Antenna/Cable: If the VCR does not have Audio and Video In connectors, then it will have
an “Antenna” or “Cable” input. The signal as sent by a TV station is a combined signal with
both the audio and video portions “in the same wire”. The connection on the back of the VCR
is likely to be either:

a) A “coaxial cable” style connector, often with a threaded barrel, or,
b) An “antenna” style connector, designed to have two leads attached with screws.

For the moment, just identify which type of input your VCR can use. If it supports both Video
In AND the Antenna/Cable inputs, plan on using the Audio/Video In, and ignoring the
Antenna/Cable input.

Before discussing the exact method of connection, let’s next look at the back of your Apple
IIGS computer.

The Apple IIGS Connections

Video: At the back of the Apple IIGS, on the right side (if your looking directly at the back),
near the power cord, you’ll see a phono-style connector, with a picture of a monitor below it.
(fig A). This is the “Video Out” connector of the Apple IIGS, and outputs pretty much the
same graphic images that you see on your regular RGB monitor.



61

Audio: At the left of the back of the Apple IIGS, is a smaller connector, with a picture of a
headphone below it. (fig A). This connector is a stereo mini-phono (1/8") connector. This is
the “Audio Out” of the Apple IIGS, and any sounds you hear from the internal speaker can be
also picked up here. A simple way to test this (and to hear just how much better the Apple IIGS
can sound!) is to plug the headphones from a portable cassette player into this connector, and
then run some HyperStudio stacks with sounds (try Read ’n Listen, for example). The sound
quality on the Apple IIGS is very dependent on the speaker you use. Any external speaker or
headphone will give very good sound quality.

Connecting Things Together

If your VCR has “Audio/Video In,” read the following section. If your VCR has only an
Antenna/Cable input, skip this next immediate section, and go to the section entitled
“Antenna/Cable Input VCR.”

“Audio/Video In” VCR

At this point, you’ve visually identified the Audio and Video Out of the Apple IIGS, and also
the Audio and Video In on your VCR. It’s now just a matter of connecting things up.

The Video: This part is easy. Just get a sufficiently long cable with phono-style (RCA)
connectors on each end, and connect the monitor connector on the GS (the Video Out) to the
Video In on your VCR.

[If the VCR had a BNC connector for the Video In, then you would use the adaptor to
complete the connection to the VCR. Don’t worry about trying to avoid the adaptor by finding
cables with a phono plug on one end and a BNC on the other. The adaptors are ultimately a
simpler way to handle the problem.]

For the cables, you can use Radio Shack catalog #42-2367 (6' cable—-$2 45) or #42-2368 (12'
cable—$3.49). If you want to be really “official,” you can buy phono-connector cables in
white, red and yellow colors. Yellow is the official color for the video signal, and red and white
for the audio (#15-1540, for example, is a color-coded, 2-wire 24' cable for $8.29; #15-1512 is
3-wire, 12' for $8.95; #15-1537 is 3-wire, 6' for $7.19). You're likely to see this same color
coding on the connectors of your VCR and TV/monitor. The wires aren’t any different inside;
it’s just a helpful way to keep the wires properly connected.

Audio: Since the “Audio Out” on the GS is a mini-phono plug, you’ll need an adaptor to
convert to the regular phono plugs on the connecting cables. Radio Shack part #274-378
($1.99) will do the trick here. On the other end of the wire, if the VCR requires a BNC
connector, you’d again use a BNC adaptor to make the connection there. Otherwise, the phono
plug will work just fine.

At this point, the Audio and Video connections have been made, and you should proceed to the
section entitled “Testing the System”.
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“Antenna/Cable Input” VCR

You’ve identified the Audio and Video “Outs” of the Apple IIGS. The problem is that the
VCR wants the equivalent of Channel 3 or 4 as an input—that is, a combined audio+video
signal as would come in from a TV station.

Again, Radio Shack comes to the rescue: Radio Shack Catalog #15-1273 ($27.95) is an “RF
Modulator” that combines the Audio and Video from the GS, and converts it to Cable-TV-like
Channel 3 or 4. So, to hook this up, you would first use a short (3' for example—RS #42-2309
is a set of four 3' color-coded cables for $5.69) pair of cables to run the Audio and Video Out
from the GS to the Audio and Video In on the RF Modulator.

The RF Modulator then has a “TV QOut” connection that expects a coaxial-style cable. At that
point, it would probably be easiest to run a coaxial cable from the RF Modulator to your VCR
“Cable” input. (RS #15-1531, for example is a 16' cable with coax connectors on each end).

If your VCR has the twin-screw type input, Radio Shack catalog #15-1522 ($4.99) adapts the
coax-style to antenna-style connector on the TV.

As you’ve probably gathered by now, TV/monitors with a direct Audio/Video In connector are
much easier to deal with than Cable/Antenna input only, and so this feature is a good thing to
check for when ordering new equipment.

Testing the System

At this point, everything has been completed so that you can record both the audio and visual
part of a computer presentation on the VCR, while the class is viewing the presentation on the
TV/monitor. Now, to test the system, follow the steps below.

1. Tum on the TV/monitor, the computer AND the VCR. You’d be surprised how often
people forget to turn on the VCR and wonder why there’s no picture on the TV/monitor!

2a. If you’ve used the “Audio/Video In” for the VCR, then look for a switch on the VCR that
says something like “Line Input,” or “Input Select.” This must be set to tell the VCR to
display and record the signal coming in from the Audio/Video In, rather than a TV station.
Some newer VCRs have very few controls on the unit itself, and you may have to use the
remote control for the VCR to activate this function.

2b. If you’ve used the “Antenna/Cable” input method, make sure that the VCR is set to
Channel 3 or 4 (whatever matches the RF Modulator switch setting). As described in step 2a,
above, this may be a switch labeled “Line Input,” “Input Select,” or may even be located on
the remote control for the VCR.

3. At this point, you should see the computer image on the TV/monitor screen. If you click on
a button that plays a sound, or do anything on the computer that generates a sound, you should
hear it through the TV/monitor speaker. You may have to tun up the volume control to hear
the sound.

NOTE: When anything is plugged into the headphone connector on the Apple IIGS, the
internal speaker is automatically turned off. So, if the TV and/or VCR are turned off, you will
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not hear any sound from the computer itself while the connecting cable is plugged into the
headphone (Audio Out) jack of the Apple IIGS.

4. Even without a video tape being recorded, this is basically the configuration you would use
in the classroom for teacher or student presentations. When you want to make a videotape, just
press the Record button on the VCR, and everything will be recorded—as simply as that.
Many VCR’s have some variety in recording speed options. You’ll probably get the best
results on the “two hour mode” (“SP”), although other modes will also generally work.
There’s nothing wrong with experimenting with the different tape speeds to see which works
best for your purposes.

Adding Other Sound Sources

The configuration described above only records sounds from the computer (along with the
visual images, of course). At some point, you’ll start thinking it would be nice to include the
student’s narration as they gave their presentation, or perhaps sounds coming from other
sources such as a laserdisc player, CD-ROM audio, or MIDI keyboard.

For the student’s narration, you may be able to get by with using the “Audio Dub” input found
on some VCRs. (See the VCR manual on how to activate the “audio dub” feature—it may
even be automatic once a microphone is plugged in!) You can plug the HyperStudio
microphone right into this input on the VCR, and the student’s voice will be mixed in with the
computer sounds while the tape is being made. If you find the HyperStudio microphone cable
a little short, and want a more sensitive microphone, you may want to try Radio Shack’s #33-
1063 “Tie-Pin” microphone. This is a very nice “lapel” style microphone with a good long
cable on it that will work well during student or teacher presentations.

One tip here, though: the “Feedback” problem when recording with amplified speakers (like
the one in your TV/monitor!) is mostly a problem of just having the microphone too close to
the speaker. So, keep this in mind, and try to keep the student or teacher with the microphone
at least 6' away from the TV/monitor while they’re giving their presentation.

If your VCR doesn’t have an “Audio Dub” input, or you want to have control over the volume
of the computer and microphone sounds, or you have other sound inputs like a laserdisc
player, CD, etc., what you really want to ultimately get is the “Four Channel Stereo Mixer”
($69.95—RS #273-1454). This really is highly recommended if you discover you really like
this idea of recording the computer on videotape. If model #32-1200 (Five channel mixer,
usually $119.95) is on sale for the same price as would normally be charged for the Four
Channel mixer, then this is a good deal. However, do not get the Stereo Microphone mixer
($34.95—#32-1105), since that unit is intended for microphones, not the “line level” output
which is required for your VCR.

The idea behind the mixer is simple: You’ve got only one sound input on your VCR, and
suddenly you’ve got lots of other sound sources, some of which don’t even have volume
controls. The mixer is just a simple box with lots of “Audio In” jacks and one “Audio Out.” If
you do get one of these, use figure B for a guide on where to plug in the various sound
sources.
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Classroom Notes

The VCR is a natural heir to the function of the printer. In the world of multimedia where a
presentation can include sounds, animation, and even video clips, the paper-based printer just
can’t compete. Almost everyone has access to a VCR, and it becomes a universal medium of
communication.

You may wish to have each student bring a blank tape of their own in at the beginning of the
year, and collect their own “portfolio” of projects they create during the class. The motivational
aspects of creating the same type of medium that they see used every night on TV is difficult to
over-state. Parent reactions are (not too surprisingly!) very favorable, and it’s a positive
experience for everyone concemed.

It is also possible to interchange “sources” of the video input when you create a tape. Once
you’re comfortable with videotaping from the computer, try pausing the VCR while it’s
recording, and substitute a camcorder as the video input to the VCR. You can then record an
“introduction” from the student, or closing remarks at the end. You can also switch back and
forth several times between the computer and another VCR (as a video source) or camcorder,
and mix in segments of computer-generated segments with live commentary, footage of the
school, local historical sites, etc.

Sharing the TV With Classroom Cable

About the only other consideration that comes to mind is if your TV/monitor is set up
permanently in your classroom, and you have a cable TV as your usual input, you may want to
be able to switch between the computer display, and the “from the wall” signal already in your
classroom. The TV/Monitor itself may have a built-in switch that goes between “Line 1” and
“TV/Cable”. If not, Radio Shack (who else?) has a variety of switch boxes. RS #15-1249
(86.99), for example, switches between two cable (75 ohm) style inputs.



65

Parts Summary

Since there were a lot of different pieces of hardware listed above, here’s a quick summary of
what you need, depending on your VCR:

“Must Have” For the Apple IIGS Computer:

For adapting headphonejack to phono cables.
For “Audio Out” from GS #274-378 phono/mini plug

If you have a “Video In” VCR:

Connecting cables: #42-2368
Pair of 12' phono-style cables for the audio and video signals from the GS to the VCR.
If your VCR “Video In” has a BNC connector:

Phono/BNC adaptor #278-254 ($2.50)

If you have a “Cable In” VCR (no video in):

3' connecting cable #42-2309 ($5.69)
RF Modulator #15-1273 ($27.95)
16' Coax Cable #15-1531 ($4.89)

If you have an “Antenna In” VCR:
Coax-style to Antenna-style connector: #15-1522 ($4.98)
To Add Student Narration:
HyperStudio microphone if your
VCR has “Audio Dub”
Tie Pin microphone is more sensitive #33-1063 ($27.95)
and longer cable.

For volume control and/or more sound sources:

Four channel Stereo Mixer #273-1454 (369.95)

“Ok, So What’s the Deal With Radio Shack?”

By now, you probably think that RWP must own stock in Radio Shack. Well, the simple truth
- is that Radio Shack just has three things going for them:

1. They have virtually every little gadget and gizmo you will ever need to get all your
hyper/multimedia equipment working together.
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2. There’s seemingly no place on earth where there isn’t a Radio Shack store within spittin’
distance that has just that part you need. Isn’t it wonderful that we can list an exact part
number, and know that virtually anyone reading this page will be able to get just that part with
a minimum of effort and expense?

3. Generally speaking, they’re always willing to be helpful and courteous, even if you’re just
buying a $2 part.

Need we say more?

Diagram of How to Attach the Apple IIgs to a VCR

For "Audio Qut” from [IGS:  #274-378
(figure A) Phono/mini plug for adapung headphone jack to phono cables

=@ Qut to VCR “Audio In”

#® From IIGS headphone jack

£ ' —<&——-8 From laserdisc player (optionai) (<1} han

]-é‘ From microphone (tie-pin or HyperStudio)

. o = L ocncs ; A /
(figure B) _,,_,O @ 5) g @ (©) © ‘

You can optionaily use either of these inputs for a MIDI keyboard or CD-ROM
audio out. (The "stereo/mono" switch on mixer should be in the "mono" position.)
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HyperStudio Tips

This is a brief outline of special techniques available in HyperStudio that would be of use to the
advanced user. For the most part, they involve using the Apple or Option keys to enable
special short-cut features. A few of the tips are provided as reminders of functions that are
somewhat obvious in HyperStudio, but that the beginning user just may not have thought
about.

Text Field Keystrokes

The following keystrokes can be used while the cursor is within a text field:

Apple-Right Arrow: move to next word to right
Apple-Left Arrow: move to next word to left
Apple-Up Arrow: move up one window
Apple-Down Arrow: move down one window

Option-Right Arrow: move to end of line
Option-Left Arrow move to beginning of line
Option-Up Arrow: move to beginning of text item

Option-Down Arrow: move to end of text item

From a given location, pressing:

Shift-Option-Up Arrow: select everything to the beginning of the document.
Shift-Option-Down Arrow: select everything to the end of the document.

Control-D: delete character at cursor
Control-Y: clear all text to the end of the line
TAB: go to next text field on the card, if present.
Double-click: select an entire word
Triple-click: select an entire line

Other short-cuts

When a button is selected, choosing a color from the Colors menu will set the text color inside
the button.

If the eraser is chosen, choosing a color from the Colors menu will set the background color.
When a paint tool other than the eraser is active, if you hold down the Option key while you

choose a color from the Colors menu, the background color will be set, without affecting the
current color of the paint tool.
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If you select a text field, choosing a color from the Colors menu will set the color for all the
text in that text item. If you hold down the Option key while you choose a color, then the
background color for the entire text item will be set.

Resizing graphics: if you select a part of the background graphic (with either the lasso or
square selector), the graphic can then be resized. After selecting the graphic and getting the
“marching ants” border, put the tip of the arrow cursor anywhere near the lower-right corner
of the selected area, press and hold down the Apple key, and then press the mouse button
while you drag down and to the right. The graphic will then be scaled to a larger size. If you
drag up and to the left, the graphic will be reduced in size.

If you hold down the Option key while a graphic is selected, and drag the graphic with the
mouse, an instant “copy” will be made, which you can place at a new position. This can be
useful for creating borders, repeating patterns, or just quickly replicating a small graphic for
use in multiple locations.

If you have a rectangular shape (for example, a solid border around a blank interior), there are
some tricks for lengthening or shortening the shape as needed. To shorten (either vertically or
horizontally), just use the square selector tool, and select a quarter or so of the top, bottom, or
left or right edges of your shape. Then slide the selected image back on top of the existing
graphic. The net effect will be to make the shape a little shorter.

To make a graphic longer, hold down the Option key when you press the mouse button to start
dragging the selected region. This will make a copy that, when overlaid with a slight offset,
will extend the graphic. Both these techniques are similar to what you would do with wallpaper
when trying to fit a specific-sized area. This is a little difficult to describe with words, but is
pretty easy to grasp if demonstrated. If you can’t get someone to show you, experiment a little
and you’ll probably be able to see what we’re talking about.

Straight lines: if you have problems drawing (or erasing!) in a straight line, try this. If the Shift
key is held down when you start to draw a line, or move the eraser, the motion will be
“constrained” to a perfectly horizontal or vertical path. The horizontal or vertical direction is
determined by which direction you move the mouse first. This also applies to when you drag a
selected region. For example, if you select a graphic area, and then hold down the Option key
and the Shift key, and then drag the graphic, a copy will be created, and then moved perfectly
horizontally or vertically to a new position. This can be handy when lining up small graphics
(like arrows) for a list of items on the screen.

Using the Shift key can help you erase along the edge of a graphic. Finally, if you hold down
the Shift key while you draw with the oval or rectangle tool, you’ll get a perfect square or
circle.

Creating buttons over text: remember, that when you move the cursor over a text field,
HyperStudio usually assumes you want to enter or edit text, not click on a button. If you want
to create a button over a word or phrase in a text field, first make the text field “read-only.”
Then the cursor will stay as the “hand” when you move over a text field, and you can create
buttons that overlay existing words on the screen. It is not currently possible to create links to
words that are in scrolling text fields since the word can move.
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Color replace: many people don’t notice the item in the Options menu called “Replace Colors.”
This is a handy paint tool that will manipulate all the color pixels in any selected area. Having
selected a part of the graphic background with the lasso or the “rectangle” selector, just choose
“Replace Colors.” You have the option of either replacing all occurrances of one color with
another, or swapping two colors. Replacing is an easy way to change a green arrow into a blue
arrow (for example), without having to use the fill tool or the magnifying glass. The exchange
color option can quickly “invert” an image. For example, try swapping black and white (or a
light/dark color pair) for an interesting effect.

Color replace can also be used to quickly create a ““drop shadow,” or three-dimensional look.
For example, let’s suppose you had a green arrow. Position the arrow somewhere on the
screen away from its final location. Use the Option key to make a copy of the arrow, and drag
it to where the arrow image will finally go, but don’t drop it in position yet. While it’s still
selected, use Color Replace to change the green color to grey. Then drop the now-grey arrow in
place. Now, lasso the original green arrow (which you’ve put off to the side somewhere), and
drag it on top of the grey “shadow.” A good place to put it is above and to the left of the grey
image, so you get the impression of a shadow. This technique can be very impressive with text
titles created in a large font.

Pop-up fields: on some occasions, you may wish you could have an image “pop up” on a card
when a button is pressed. There are two ways to do this. The first, “brute force” method is to
just create a second card, that looks identical to the first, except that it has an additional text
field, graphic, or whatever you wish to appear. A button on the first card then moves to the
second, with the “fastest” transition, to create the “pop up” effect. Another button can move
back to the first card to make the pop-up item “disappear.”

Another approach is to create is a one-frame animation. Use “Save Screen” (in the File menu)
to save an image of the screen with the word, graphic, or whatever it is that you want to appear.
Save it with a name that ends in a number, such as Lion. 1. Now, create the triggering button,
and have it trigger an animation. Select your single graphic image as the “animation” to play,
and crop the screen as necessary so that just the image that you want to “pop up” appears at the
desired location on the screen. Use a Rate and Repeat Count of “1”. To test your animation,
click the button to trigger the animation. If the screen doesn’t change, you’ve done it correctly.
The final step is to refresh the screen (move off the card and back on), and then use the eraser
tool to erase the image on the screen that “pops up” via the animation on the button.

The advantage of one frame animation pop-ups is that they are very fast. To make the image
g0 away, create a button that moves to the same card (use the option for “Move to Another
Card,” and then simply click on “Ok” instead of moving to another card). The effect will be to
refresh the original screen, thus erasing the “popped up” item. You can combine multiple
buttons, each with a pop-up graphic, for very interesting effects. Imagine a “Mr. Potato Head”
where you add different parts, or pictures of a variety of animals in Africa!

Common backgrounds: this last topic sounds complicated, but it’s worse to explain than to -
use. Normally, when you create a new card, HyperStudio erases the background, and you get a
blank white background on a new card. But, suppose for a moment that you were creating
pages in a notebook for a class roster. If you’re using exactly the same background for a
number of cards (the image of a notebook page), why not have HyperStudio remember this,
and re-use the image from a card, rather than having to re-load the same image over and over
again? This has been provided for in HyperStudio, and is found under the Apple menu, in the



70

Preferences dialog box. By making sure that “Erase Background on New Card” is not
marked, HyperStudio will default to not erasing the background when you choose New Card,
and will save memory by using the background on the “parent” card for all “children” cards.

The “parent” card is simply whatever card is displayed when you choose “New Card.” A card
remains a shared “child” card until you draw 'on the background. So, if you want to use this
technique to save memory, it is important to remember to only place objects on each card. That
is, each card is individualized by adding text objects, graphic objects, and buttons on a card. If
you draw on a child card, it immediately is removed from the “group” and becomes its own
background (and therefore, a new “parent” card). One other thing to notice: if you draw
something on the original parent card in any group, that addition is automatically repeated
among all the other members of the group. This is a very neat way of making changes to
(conceivably) hundreds of cards in just one motion!

Speed or Memory: How to Choose

Sounds in a stack can either be accessed very fast by being embedded right in the stack (the
usual, or “default” situation), or they can be disk based. Making the sounds disk based means
you can use many, many more in a stack, but the access time will be a little slower than when a
button is pressed, as HyperStudio must go out to the disk to get the sound file. Embedded
sounds are easiest to deal with for beginning users, and for sound feedback for very young
users, the instant access of an embedded sound may be important.

However, even 3rd graders can leam how to use Sound Shop to record a sound outside
HyperStudio, and then save this sound on disk. To enable the disk based option, go to the
Apple menu, and check “Advanced User” in the Preferences dialog box. The main function of
this option is to then ask the question “Disk based or embedded?”” whenever a sound, graphic
or text item is added from a disk file. Choosing “disk based” will mean you can put more -
sounds in a stack, and the sound will only be loaded for the moment it is played. One other
advantage of using Sound Shop is that you can see the “silence” at the beginning and end of a
recording, and cut it out with the editing tools. This can save a lot.of memory when a large
number of sound files are involved. The use of Sound Shop can also be used as part of a
science curriculum to explain sound waves, and the physics of sound: pitch, amplitude, and so
on.

Speaking of conserving memory, remember than a text field uses much less memory than
painting words on the screen. Also, with a text field, you can go back and insert letters, and
easily edit the words later on if you wish. Try creating a text field with no rectangle frame, no
scrolling, and no scroll bar. Type a few words in it, then, select the text item with the pointer or
text-item tool (in the Tools menu), and choose Set Background Color from the Options menu.
Set the background color to the same color as is behind your text field. The result is that the
text is now indistinguishable from a title or other text you would have “painted” there. The
advantages of text fields is that they take much less memory, and can be edited later. On the
other hand, it takes a little longer to build a card with a text field, so going from one card to
another will be a little slower. Also, the same font used to create the text field must be in the
Fonts folder of your startup disk when this stack is accessed (or when your end user uses the
stack), or else you'’ll get a horrible looking blocky Shaston font, instead.
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Card 1
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Important! The browse tool must be selected any time that you wish to click a button. You
will know that is it selected when you see the hand appear as the cursor.

The following tools all work under the same basic principle. When the tool has been selected,
the cursor changes to a cross-hair. In order to use the tool, move the cross-hair to the upper-left
side of the area you want to enclose. While pressing on the mouse button, move the mouse
diagonally across the area, ending at the lower-right side of the area. These tools work in this
manner: Selector Tool, Line Tool, Rectangle, Rounded Rectangle, Oval, Freehand Shape, and
Polygon.

In addition, the Selector Tool leaves a dotted, blinking box surrounding the area you have
enclosed. While the rectangle is blinking, you can do the following:

o Cut or Copy the contents of the rectangle to the clipboard.

» Delete the contents by pressing the delete key. This is an easy way to erase unwanted
images. '

» Move the selected area by placing the cursor within the rectangle. Press down on the
mouse button while you drag the rectangle with the mouse. When you release the mouse
button, the image will be placed at that location. .

If you change your mind about the area you have selected, clicking the mouse once outside the
selected area removes the selection box.
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What Happens When You Choose Add a Button?

First, you must choose your button style. The dialog box pictured below will appear, and
you must click the button style you desire. ‘

Next, you may
type in the text Adding a button:
that will appear
on the button.

Select a button style:

( )| | | | ] [Invisiblef

After you have
chosen your
button and
typed its name, |
click “OK” to - -
accept your
choices. If you
decide that you -
don’t want to create a button, choose “Cancel”.

Enter button name:

Once you click “OK,” you will be asked to place the button on the screen.

Lastly, ilou will see the Button Actions Screen (below). Click next to the actions you wish this
button to execute.

| & File Edit Move Tools (R334 Colors Options Cord 14 |
’ Choose button actions:
Connect to: " Rctions:

O fnother card... [JPloy a sound...

C Next card [JPlay a video...

O Previous card I Trigger XCMD...

O Home stack [IRctivate animation...

O Back Rate Repeat count

(O Another stack...

8 :?::;::?i:;l" [ futo-activate after delay

I Continuously re-activate . |

O Correct answer Delay in seconds:

O Alternate answer : !
@ No test effect I
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Recording Sound in HyperStudio

l_i File Edit Move Tools I:Im Colors Options Cord 15 |

Yolume Level

Erase | Record | Play | Stop @ Record voice

Q© Recordmusic

Before you actually record your voice, practice speaking the phrase you’ll be recording with a
“radio announcer” voice. Hold the microphone close to your mouth and speak firmly. You
should see the level indicator on the right jump as you speak.

When you’re ready to record, click the “Record” button. The screen border will turn green.
When you begin speaking, it will turn red, showing you that recording has begun. When you
finish speaking, press a key to stop recording.

To hear what you’ve recorded, click the “Play” button. To adjust the volume, move the
volume slide control. If you don’t like the recording you made, simply click “Record” again
and start over! ‘

When you are happy with your recording, click “Done.”
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HyperStudio System Setup Check

This page details system setup parameters that should be checked before beginning the
Hands-On Walk Through in this workbook. This system check can be performed by either the
person setting up the workshop before the attendees arrive, or by the attendees themselves if
they are sufficiently comfortable with accessing the Control Panel on the Apple IIGs.

Control Panel Settings

To access the Control Panel on the Apple IIGS, hold down the Control and Apple keys, and press
the Escape key. This will give a text menu with “Control Panel” as the first item. Use the arrow
keys (if necessary) to highlight the words “Control Panel,” and press Return. Use the arrow keys
and Return again to check the following Control Panel settings.

RAM Disk
Use the arrow keys and Return to select “RAM Disk” from the Control Panel menu.

On an older Apple IIcs (ROM 01), the first two selections will be “Minimum RAM Disk
Size” and “Maximum RAM Disk Size”. Use the left and right arrow keys to set both values to
@K, if necessary. Note: although different values are allowed in these two settings, experience
has shown that the system operates better when both values are the same. For HyperStudio on
a 1.25Mb machine, the RAM disk setting should be at zero to allow maximum memory for
your stacks. :

On the newer Apple IIcs (ROM 03), the first selection will be “Select RAM Disk Size”. Use
the left and right arrow keys to set this value to @K, if necessary.

Press Return after making any necessary changes to return to the Control Panel menu.

Sound
Use the arrow keys and Return to select “Sound” from the Control Panel menu.

The “Volume” setting should be at least at standard (checked) level, or-higher. The real test
is to press the space bar. If you can hear the system beep reasonably well (remember there will
"be other room noise present during the workshop), then that’s fine. If you wish, you may want
to increase the sound level with the right arrow key until you can easily hear the system beep.

Press Return after making any necessary changes to return to the Control Panel menu.

‘System Speed
Use the arrow keys and Return to select “System Speed” from the Control Panel menu.

The System Speed should be on “Fast”. Sometimes Apple IIGS machines are set to the
“Normal” (slower) setting to accommodate older Apple II programs, particularly those that
use a game controller or joystick.

Press Return after making any necessary changes to return to the Control Panel menu.
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